I cant get it to turn on

I cant get the thimg to turn on.
I opened up the bottom, screwed in the wifi chip, the ram chip, and the memory chip, screwed it all back together, put it on the charger for over an hour.
Press the power button and the power button will light up for about a minute and then stop lighting up.
The screen remains dark the entire time during this process. non of the lights for the keyabord light up during this time.
I tried plugging in a separate keyboard and non of the lights work on that keyboard either. Even though that keyboard works on my other computer.
Contacted support and they haven’t contacted me back. Please help!!!

If you have a single memory chip it goes in the second slot, not the first. That confused me at first (amd, diy), and if you get it wrong, the screen just stays dark.


Note: If you are using one Memory module, place it in the right socket that is labelled “Channel 0."

Channel 0 didn’t work for me, or for others too (I got the tip from SuperSleuthers comment on the quick start guide)

Ok, i switched the memory stick over to the other socket and … still nothing.

Ive tried both slots…

Please update your post to include answers to each of the questions listed in the Community Support template post.


Are you looking into the forum because you’re having potential issues with your Framework laptop? Before creating a post, we may have a guide, FAQ, or thread that can hopefully help!

In the body of your post, please include those following details.

  • Which OS (Operating System)?
  • Which release of your OS (Operating System / Windows 10, 11, Distribution of Linux)?
  • Which Framework laptop (11th, 12th or 13th generation Framework laptop) are you asking for support with?
  • If this is a Linux issue, please use the Linux tag or at least put Linux in the title.
  • If there is no information pertaining to your issue or question, please let us know here: Framework | Support Framework | Support
1 Like

Shame, sounds like it wasn’t that for you. I’m not sure what other options there are since that was the problem for me. Did you follow the quick start guide? For the AMD laptop it’s here but there are guides for each sort.

Yeah. It seems to be working now.

1 Like