Installing Windows 10 over Linux- Having Serious Installation Issue

Okay, so after accidentally installing the non-Edge version of Linux Mint and ending up with a nonfunctioning device, a helpful person on this forum (@Fraoch ) suggested I install Windows first and then install Linux second. So I successfully imaged a flash drive with a Windows 10 ISO, and after changing the BIOS boot sequence in terminal, was finally able to get the Windows Installer to load.

However, I’m now having serious problems- I really hope I didn’t brick my brand new machine. At the installation step (where you choose a partition to install Windows on), the Installer displayed several partitions (from the previous Mint installation)- but warned me that none of them were formatted correctly for Windows (obviously). So, I selected the ~1 TB partition and clicked “Format” and then it let me begin the Windows installation. However, about 5 minutes into the installation, I received an error message saying the installation couldn’t continue and to restart my computer. I did that, and now the partition scheme is a mess. I have tried deleting the primary partition and trying again, but now the installation won’t even begin-- with a message saying “We couldn’t create a new partition or locate an existing one. For more information, see the Setup log files.”

Obviously, I no longer have any OS on this machine, and I’m afraid if I wing it that I will dig myself an even deeper hole. Sorry to ask these boards for help twice in one day, but I don’t want to screw things up further…

Alright, so just delete every single partition (with the obvious exception of the EFI one)? Then it should let me create a new one?

Also re: running fdisk from command prompt…won’t GRUB bash shell be gone after I delete the old Linux partition?

I hope I haven’t given you bad advice!

Linux will recreate all this when you install it later.

So, just to update people in case it’s helpful for anyone else, deleting all the partitions in the windows installer worked, but the installation still failed. So my only option is to format using the command prompt on the Windows boot drive.

Just fyi, fdisk is depreciated in Windows and the current command shell program is ‘diskpart.’ At first, diskpart was giving me an error when trying to ‘clean’ the drive, telling me it was ‘not allowed on the disk containing the current boot, system, pageful or hibernation volume.’ This is strange because I have booted from USB, not the drive in question. What finally worked was to re-run the Windows installer and use the GUI to delete all partitions–but then, instead of running the installation, I went back to the command prompt and ran diskpart again. This time, it allowed be to clean, create primary partition, select, activate, and format fs=ntfs. It’s still formatting but hopefully the installation will work now, fingers crossed.

1 Like

I shouldn’t have allowed myself to be optimistic. Ran the Windows installer and it won’t let me install to the newly formatted disk, saying “the selected disk has a MBR partition table. On EFI systems, Windows can only be installed to GPT disks.” So, I did some digging, and was able to run a simple command in diskpart to convert to GPT. Buttttt, the installation is still failing, now saying “Windows could not prepare the computer to boot into the next phase of installation.” Several hours now, total nightmare.

Its not like windows first linux second, if you ever want to install windows after linux you just have to run grub-install and update-grub, in order to make the linux efi entries up on the boot menu:

Having problems with both Windows 10 and Linux Mint, I’m wondering if there is something wrong with the drive?

What is the make and model of the drive?

@RandomUser I downloaded the Windows 10 ISO directly from Microsoft via Microsoft Media Creation Tool- the very latest version Win10_21H2_English_x64.iso. SHA256 hashes match. My only other computer is a Macintosh, so I used Terminal to create a bootable flash drive–I did get an error when attempting to flash the Windows ISO onto the drive, saying install.wim was too large for FAT32. So I found a program called wimlib to split install.wim into two. After that, the operation succeeded–but I’m not sure if there’s a way to verify that what I have is an uncorrupted boot drive. I’ve formatted and repeated this procedure 3 times.

@Monster_user As for the actual make and model of the external flash drive, it is actually the 250GB Framework Expansion Card. I am traveling right now and it’s unintentionally the only flash drive I have right now. Could this be causing my issues? Perhaps too large?

EDIT: Just picked up a 32GB flash drive from Walgreens. I’ll give that a go.

So, I just came across a Jan 2021 forum post saying that the aforementioned wimlib program doesn’t work on Macs with Big Sur or later. So, I am stuck because install.wim in the Windows ISO is >4GB. Aye caramba, obstacles at every turn. I can’t be the only person that is coming to Framework from Macintosh. There doesn’t seem to be a way to make a Windows boot disk from a Mac computer- at least not an easy way. Maybe I should start with flashing Linux Mint Cinnamon Edge and use the Linux command line to make a Windows boot drive. What a hassle. It’s 2022- why is FAT file-size limitation still a thing???

Sorry you’ve had so many problems!

That sounds like the best course of action. Have the installer wipe everything (i.e. select “use entire drive”). If you can, format the drive GPT first. You may need to do this from the live environment, before you install. GParted can help with this, but if this step starts to cause you problems skip it.

Got Mint up and running just fine. Thanks everyone. I’ll tackle Windows another day.

1 Like

I got around the wimlib limitation by just doing

brew install --ignore-dependencies wimlib

Then it worked fine.