Intel 13th Gen Touchpad Buttons Not Working Windows 11

On my 13 inch 13th gen Intel that I got yesterday I haven’t been able to get the physical button on the touchpad to work.

All other touchpad functions work fine, tapping, gestures, etc. So I don’t think it is a hardware problem. The buttons are not stuck as I can still hear and feel the clicking, there just isn’t a response in the software.

I originally ran into this problem when I first installed Windows 10 and the latest driver package on the laptop. But when I couldn’t figure out how to turn on the touchpad buttons, I installed Windows 11 and reinstalled the drivers. But still no change.
I read through this guide: My touchpad isn't working

But it didn’t fix my issue and the guide is two years out of date, so it might not even be applicable.

Yesterday I submitted a help ticket, but the support system has a lot of requests at the moment. I can’t find any cases of this happening to Framework laptops since 2021, and it sounds like that manufacturing defect was corrected back then. So I would assume this isn’t related to those older posts.

Is there some simple fix or troubleshooting step I am missing here?

Hi. Are you sure you have the correct drivers?

The downloaded filename is: Framework_Laptop_13th_Gen_Intel_Core_driver_bundle_W11_2023_03_28

Have you tried reseating the cable?

That is the same filename as what I used. I got it from Framework Laptop BIOS and Driver Releases (13th Gen Intel® Core™)

I followed the Touchpad Replacement Guide to remove and re-seat the touchpad cable. Still no change.

1 Like

Open Device Manager. If your drivers were installed successfully, the “Other Devices” category should not be listed and there should be no unknown devices.

(The BIOS setting “PS2 Mouse Emulation” is normally set to Auto. My understanding is that this allows the touchpad to emulate a mouse before the OS-level driver is installed. If the driver is not loaded successfully, then the PS/2 emulation continues and is a bit flaky in my opinion. Unknown devices in Device Manager may indicate that the driver has not loaded leaving you frustrated by this flaky emulation.)

Under Settings → Bluetooth & Devices → make sure the touchpad is enabled. Under “Taps”, I uncheck the “Tap with a single finger to single-click” just to avoid activating when I really just want to use a click. (I do keep a USB mouse handy when diagnosing problems with the touchpad).

1 Like

Resolution: Framework support got back to me. After having me remove and reconnect the touchpad with no change, they had me send over some pictures and a video of what was happening.

After seeing all of that they determined there was a problem with the touchpad itself. Support is sending me a replacement input panel.