Internal Display Freeze on Boot, External Display Functional - Windows 11, Ryzen 7 7840HS, Radeon RX 7700s

When booting up, my Internal Display will work as expected up until the login screen. At that point it freezes. Normally I will see the login screen on both my Internal and External Displays. When this freeze happens, the External Display will be blank at first and the Fingerprint Reader, Mouse (internal & external), and Keyboard (internal & external) are non-functional.

If I tap the Power Button then the External Display will show the Login Screen along with a statis showing “Fingerprint Not Recognized.” Then, touch the Fingerprint Sensor and it logs me in.

The craziest part is that the Internal Display is permanently showing the Login Screen while the External Display is working as expected. Looking at the Display Settings, Windows 11 only sees my External Display. Tried “Detect other display” but it says there aren’t any.

I can’t figure out how to replicate this as it doesn’t happen every time. Maybe once or twice a week.

The only troubleshooting that fixes it is to reboot again. Either from Windows or hard reboot from the Power Button. Then it will boot up and function like normal.

Any ideas?

That sounds more like a software-related problem than a hardware-related one, to me. I learned long ago not to rely on such judgements-sans-evidence though.

I assume you haven’t tried a different OS (Windows 10, or any Linux distribution)?

It’s hard to troubleshoot intermittent problems like this. :slightly_frowning_face:

You’re right on the OS. I don’t have another OS to try.

Oddly, today it booted up “normally” but once I logged in, the Internal Display stayed frozen. No argument that it could be software.

My External is an ultrawide so I don’t really use the Internal except for Spotify or YouTube while I’m working. Thankfully it’s not impacting anything critical.

I suppose worse case I can re-install everything from scratch but man I don’t want to :slight_smile:

If you have a spare flashdrive on hand, you can create a bootable USB linux drive, e.g. via an officially supported distro like Fedora. The process to create those has gotten pretty easy over the years. If you can replicate the issue on there, it’s almost definitely something to do with the Framework rather than Windows.

That’s usually my first recommendation, but he said that “it doesn’t happen every time. Maybe once or twice a week.” For someone that doesn’t use Linux regularly, spending maybe half a week in it would be very painful.

1 Like