Internal Screen Not Displaying Anything when booting. Not even Bios,Any help?

So my laptop is a Batch 2 laptop, and I was using it just fine, until yesterday, I turn it on and I don’t even get the bios, but the boot sound is working, I’m able to connect to external monitor and see everything works fine. During the post test is seems that the last light blinks red instead of green. So I’m thinking my internal display is no longer working. Here are my symptoms.

Symptoms

  • Brightness Button Does work I can see the back light increasing and decreasing.
  • Laptop seems to be working just fine with external Displays
  • LCD is just black, it doesn’t seem like there is any damage.

Troubleshooting Steps

  • Opened it up and Reseated all connections.
  • Reseated Ram
  • Reseated SSD
  • Removed Bezel
  • Did Post Test and indicated that all is well except The internal Display.
  • There is no obvious external damage to display and LCD isn’t cracked.
  • Left on Charger overnight

My laptop is Batch 2, I already contacted support but I’d like to get my laptop working ASAP. Anyone experience similar issue?

1 Like

I know you already tried reseating everything but start removing things like memory and see if it errors out when posting… beeps or flashing LED etc… probably be best to confirm the issue is with the screen first and not something else. Also… can you connect an external display?

Yes external screen works just fine.

From this page if it is the last light prior to the second group of blue/green lights, it indicates that the internal display did not initialize correctly (which you obviously already know).

You mentioned that you re-seated everything, did that include the display cable? That’s the only thing that I can think of. Hopefully you are able to get it resolved soon, whether it’s the connection or replacing the display.

I’ve been having the same problem and mine came in October, and it isn’t software issue since it happened with windows ten and the issue continued when I swithed over to linux mint