Laptop charging behavior

I have been using an 11th Gen Framework Laptop DIY for about 4 months. Currently running Linux Mint 20.3 as the daily driver.

Now for what I’m dealing with.

I generally use my laptop during the day, but then leave it to charge overnight. I had it charging a couple nights ago, but then it wouldn’t turn on. When I tried charging, charging LED would shine amber, but when I tried powering it on after an hour or so, it would give a POST code indicating the following:

Thermal Sensor was not detected
CPU did not reach S0 State

Post code section: bit 0 is blue

So I performed a BIOS reset, and was successfully able to get a charge for my battery. I was able to successfully boot to OS. I inxi -Fxz 'd my machine, and I got a temperature reading for CPU, so I am confused as to why the Thermal sensor couldn’t be detected.

Did I screw up with performing a BIOS reset?

Where would I check, either hardware or software wise, to see if there is actually an issue with my thermal sensor?

Once I ran through my daily use, and went to plug it in for the night, it started to behave weird again.

Plugging it in gives LED code:
Red , amber, off; red, amber, off; amber hold

Laptop wouldn’t recognize a charge with notifications. It frequently switches between the following types of connections:
“Critically low battery” and "Using battery power “~1hr remaining” for a 2% charge
“Charging” message, with no ETA on a full charge. Battery charge decreases during usage when I did some research on it’s behavior.

Maybe there’s an issue with the protocols talking from the battery, charger, etc. to OS?

I shut down laptop to get into BIOS, to get into BIOS, and everything seemed fine (considering the reset).

Now getting back into my OS, Power button will turn on, keys backlight will turn on, charging LED will turn green for a few seconds, but then turn amber, and then everything shuts off.

Sitting for a second or two, everything turns back on, charging LED flashes green a few times, and then goes back to amber. But then can boot to OS. I still get the same behavior with the charging notifications as mentioned before.

From what I’ve seen in the community suggestions concerning charging issues, I re-seated my battery. No pins were bent, so the re-seat didn’t resolve anything. The charging LED seems to behave the same way, but it would boot me directly into the OS this time around, though.

Because the battery didn’t seem to do anything besides delay the laptop booting into the OS, I wanted to do a BIOS reset, given the community info and Framework team mentioning older BIOS versions having charging/battery issues.

I cannot locate the USB that has the BIOS update data when trying to get to the UEFI screen, so I booted to my OS, and then ran it from the USB stick from there.

Now I get a new POST code, and cannot boot into my OS:

CPU Deassert sleep S4
Fan not detected and doesnt spin up
CPU doesn’t reach S0 State

Post code section: bits 1 and 6 are blue.

How can I do a BIOS update on my device, if I can’t locate the USB necessary to perform the BIOS update? I clearly screwed something up when I tried running startup.nsh from my OS after boot, so does anyone have any recommendations for workarounds?

I apologize for the length of this, but I am kind of stuck on where to go from here.

Seen soemthing similar in other posts and i wonder why use a USB stick? Maybe it’s a linux only thing.

I dual boot with Win. Download the BIOS to the desktop and run it.

Reading through your post I would highly recommend contacting support. It seems like you might be having some hardware issues, and if there’s weird stuff happening with the battery, I’d want Framework to know ASAP so they can help you replace that if need be.