Laptop wont boot, blink codes (11th gen i5)


I have my framework since the very end of last year. In the meantime, I didn´t use my laptop much but I started some projects that necessitate a lot of mobility, thatś where my issues start :

  • I cant “not charge” the laptop for a while, 'cause I’ll need to reset it completely to use it again
  • Now, after a little while of working normally, it just wont boot at all (no picture, power led lighting up white briefly, blink codes). I tried the reset procedure at least 6 times but it did not work, my blink code is : :green_square: :green_square: :green_square: :green_square: :green_square: :red_square: :green_square: :red_square: :green_square: :green_square: :green_square: :green_square: :red_square: :blue_square: :green_square: :green_square: :green_square: :green_square: :green_square: :green_square: :green_square:

From what I gather, my touchpad is not detected, the thermal sensor is not either and the blue led might mean SEC_SYSTEM_POWER_ON (from the InsydeH2O manual), meaning my CPU is booting in protected mode.
I’ve tried replugging every flex connector (that was not fiddled with before this) : no dice :confused:

Thanks in advance to anyone that will post his/her two cents on the issue :slight_smile:

1 Like

Do you mean the main board reset and then leave it pluged into power for 24hrs?


Yup, starting roughly on tuesday last week to yesterday (I let the laptop charge for like 18 to 24 hours, the button cell is fully charged, checked with a volt meter), plugged in with a Dell 90w USB-C charger, should I try a less powerful one or a specific brand ?

1 Like

The charger is fine.
The only info I have is around the main board reset which was required due to a flaw in the design of the 11Gen chip from Intel.

I can only suggest another reset as per the guide, or even contact Framework ASAP and ask them for help . . again.

If the main board reset isn’t the issue ?? with only USB C expansion cards

If you have done that, can you check the RAM, just use one slot if you have two fitted.

It may be a Framework issue so also get official support before the warranty expires.

if toy


Sorry for the late reply, had a lot of personnal things going on.
So, the reset thing is absolutely pointless in my case, even without any ex card (raw-dogging the charger into the ports directly onto the mobo) it doesnt make any spec of chnage.
Tho today whilst measuring the voltage across the button cell and then the button holder, I accidentally turned on the thing by hitting the power button : it turned on. Booted up manjaro fine but then I figured I could try and get into the bios but no dice, cannot turn it on again.
I think Iḿ going to play frisbee with this motherboard which is obviously plagued with issues (the cmos battery charge thing being absolutely scandalous) : why didn´t framework issue an official recall of those motherboards ? I paid 1k for this laptop, I expected to have a form of respect from them but the “patch our issues yourself” route isn´t what I call a good way to go about it.
In the end, I think Iḿ going to tinker with the dead mobo and buy a new one, even tho I shouldn´t need to do that, but because I don´t want a few pound of aluminium and plastic in my local landfill, I’ll do it.

1 Like