Laptop fully works except Black Screen in BIOS UI & bootloader [12th gen]

I have the strangest thing with my 12th gen I just upgraded.

It fully works except the Flash logo boot screen + BIOS (I can enter it but cannot see it) + refind (bootloader it definitely works but I cannot see it).

Once I blindly press enter to boot linux… it works, full resolution no problem at all.

What I tried so far:

  • resettle the screen connector
  • reset the BIOS: remove the main battery + CMOS battery
  • reset the nvram with modprobe nvram; dd if=/dev/zero of=/dev/nvram
  • added delay with efibootmgr -t 2 to at least try to see the framework logo at startup but nope neither.

Any idea where it could come from? Intuitively it feels like an UEFI bug of some sort.


I’m having the same problem after installing 12th-gen update kit.
BIOS is entered but screen is black. If I plug in external screen and boot to BIOS it works fine (on external screen only). If I boot to BIOS on laptop panel and then plug in external screen afterwards, the BIOS comes up on external screen (but not laptop panel).

I’ve been back and forth with Framework support over a week or so and they have run out of ideas for what might be going on.

I can think of two other possible tests:

  1. Using a different internal screen (my son has a Framework too so I may try this).

  2. Reflashing the BIOS. Can’t try this right now because there’s no download for the factory-installed BIOS.

I’d definitely bring this to support’s attention and point out that it looks like the same problem I’m having. Maybe that will up the priority enough for them to put more work into finding the problem.


What I need to add: it worked for a couple times when I received the motherboard (I switched off secure boot for example).

I am using refind and I could see it.

When I added a direct boot entry to the Arch kernel (it has an UEFI stub) it booted linux but I believe this is when it started to loose the bios (bios works but is a black screen or backlight to 0).

Support asked me to try to reset the bios but I did it blindly: F2, F9 enter, F10 enter. It rebooted but did not solve the issue.


I have a similar issue, however I cannot boot by pressing enter at this “blank screen” stage, it will just sit there until forced poweroff. I have the 12th gen i5 complete machine rather than a mainboard that got swapped in; but also my situation seems to also be related to changing hardware (happens between two RAM kits, the first one booting normal, the other one booting to this blank screen.)

Things I’m curious about:

  • If you let it sit without pressing enter to (if I follow correctly) blindly select the first item in bootloader, what happens? I’m interested if you get a post code blinking on the side LEDs, after it sits for a minute or two.
  • Is the 12th gen mainboard the only hardware that you changed during the upgrade? (i.e, otherwise exactly identical system?)

This one is probably not the same issue.
On my system the bios runs and boots up my refind.efi even if the graphical display doesn’t work. So if I short press power it immediately powers off. If I Ctrl alt del it reboots (still with a black screen bit I see it seek on USB storage).

I see, interesting. Not incredibly familiar with rEFInd, I am just using grub2. You’re right, its probably not exactly the same, just the similarities stuck out to me (including Cph’s post there as well), even considering the differences. To me, it seems, there is some peculiarity with the UEFI version shipping on 12th gen boards, that is leading to various instances of blank screen when things are/should be handed over to a boot manager (either resolvable, or not)… Just speculating tho.

1 Like

Anyone find a solution for this behavior after upgrading to 12th gen? I can plug in an external display and with the lid open it sees the screen (internal display) in Windows. However, it’s no longer a laptop at this point. Even with a monitor connected (HDMI or DP), I can not get to BIOS, ver in Win is 3.05 and for 12th gen there is no download available. Waiting on support at this point, but DOA for this weekend I guess; not a great experience.

Update - I gave up on the 12th gen mainboard for now and reinstalled the 11th gen. Guess what, the screen works perfectly… So I’m guessing they have a driver/ bios issue that hasn’t been sorted out yet or the board is DOA. I can’t say enough how frustrating this is, but at least I’m getting proficient at taking it apart and putting it back together :wink:

BTW, this was with Win11 Pro, and I did the upgrade from Win10 Pro prior to the hardware swap; as they recommended in their guide. Hope this helps someone else, as this was really the only thread that seemed relevant. I’ll post an update when I hear back from Support next week (it’s the weekend now)


Thanks for posting this @David_Wilson. Do keep us ipdated. This seems like an old thread that petered out without a resolution.

I am sure quite a few among us would like to upgrade at some point, so being aware of potential gotchas would be really nice.

1 Like

It’s been a couple of days, but have Quick update; display connector on the new mainboard was deemed bad and getting a replacement. All in all, great service from Framework.


New mainboard received and all is good; excellent support by Framework.