Microphone and 3.5mm jack not working

Up front I want to state that I have been working on this issue with support and they have been very responsive and we are continuing to work on it. My problem is not with Framework or their response. I am posting it here to get some new ideas on the cause of the problem and maybe fix it myself. The problem is that the 3.5mm audio jack and the microphone do not work on my batch 5, i5. When I got the unit in Dec, I put Windows 10 on it and upgraded to Windows 11. When the new driver package for Windows 11 and the firmware update (beta) came out I followed the instructions and installed them both with no apparent problems. My camera, speakers, fingerprint scanner and display work ok. When I decided to try to use the unit on a Zoom call about 10 days ago, I discovered the mic wouldn’t work and when I tried the jack it didn’t work also. I had loaded POP_OS on a 250gb expansion card so I booted into that and reformatted my C drive. I then took the exp card out and did a clean install of Windows 10. Same problem. I did some troubleshooting with support which resulted in them sending me a new motherboard. I followed the guide and installed it without any apparent difficulties. When I booted up again into Windows 10, I still had the same problem(s), no mic or jack. I’ve returned the UEFI to default settings in case I had inadvertently changed something but no joy. I’ve tried every setting/permission I can find in Windows 10 to no avail. I also tried using the voice recorder program in POP_OS (with no luck) to see if it is a Windows only problem and it doesn’t appear to be. Support told me that those two functions only come together in the CODEC and that was why they had to send me a new motherboard. If it’s not the motherboard (assuming they sent me a good replacement motherboard) and it happens in both Linux and Windows then that seems to me that it’s something on the webcam/mic module and the audio card (two problems coincidentally), or it is something in the new firmware update as I wasn’t able to find how to revert the firmware (if you can) to 3.0? I know I can get a USB webcam and use a 3.5mm audio to USB C adapter as work arounds but I’d like to get this working correctly. Any ideas?

Posting for record purposes and to help anyone else with the same problem searching for help and stumbling on my original post. Framework support sent a new motherboard with the tempo chip. When installed, followed by a clean Windows install and the Framework drivers it solved the problem with the 3.5mm audio jack…both audio in and audio out work thru the jack. The problem with the internal microphone remained and Framework sent out a new webcam module which works perfectly. What started out looking like one problem turned out to be two problems. Framework support listened to me, had patience and we eventually solved the problem. Kudos to them.


Thanks for the follow up, and glad to hear the team was able to help you!

1 Like

I think it’s time someone from the Maker community build a Hifi DAC w/ mic support as a module. Looking forward to seeing a laptop with actually high impedance output. Apple claimed the new Macbooks would have a high impedance mode but the output was extremely average. Theres so many high end high power dongles on the market right now I don’t see why people couldn’t make a decent module for it.