Monitor (ACER UHD 2k4k) connection issue - can't change resolution (screen tiny)

I am having issues connecting my Framework laptop to my monitor - an ACER UHD 2k4k (2014). The result any time I try to connect it is a tiny second screen on the monitor. I have tried changing the resolution in display settings for the extended display, but the option to change is not provided (it’s set - my computer gives the only resolution option as 640 x 480). I have tried numerous different connectors, which have either not worked at all or the same thing happens (tiny screen). I have updated the drivers (as per some advice online), but that has not helped anything.

If anyone has had this issue and has found a solution, please let me know!

Hi and welome to the forum.

So what OS are you using? and how are you trying to connect?

Where did you find that setting?

Windows 10. The monitor has a display port connection port, so I have been trying different DisplayPort cables (to USB-C). The 640X480 is the resolution in display settings (system settings on laptop) - under the second screen “scale & layout” options when there are multiple displays detected.

Sorry I have Win 11 and the settings are a bit of a mystery re Win10 and as I don’t have such a cable I’d best leave it to someone else to help you.

All the best

Can you take a photo of the physical cable and connection of what you mean by that?

I will assume you have purchased the DisplayPort expansion card from Framework. Correct?

And what’s the exact model of the monitor?

They already specified “DisplayPort cables (to USB-C).”

1 Like

“I had eggs for breakfast”…doesn’t exclude having toast as well. It’s left out of the communication.

So, having the DisplayPort cable mentioned, doesn’t mean the DisplayPort expansion card was purchased, or not.

I don’t know what I don’t know…so I thought I would ask.

Hey folks,

Yes - I have the DisplayPort expansion card. I have attached photos of the different types of cables I have used ( & have also purchased and tried different brands of these as well - none have worked); there is also a photo of the Display settings when I connect the monitor. The monitor is an ACER UHD 4k2k, model #XB280HK - manufactured in Sept 2014 (photo attached also).

For your particular monitor, someone faced the same issue from Dell’s forum:

However, the monitor is known to work with DP<–>USB-C cable:

…I think the last comment from the Dell thread sums it up.

Worst case: Buy 5 different DP(male)-USBC(male) cable, 5 different DP-DP cables, and 5 different DP (female)-USBC(male) adapters…and see what works. Return the ones that don’t.

Even happens with an XBox:

The monitor seems to have compatibility issue with non-nVidia hardware? Early days 4k implementation…