My Caldigit TS3 is not working correctly with my 12th gen Framework


I’ve had the Caldigit TS3 for more than 4-5 years now and it has worked perfectly with every Thunderbolt laptop I’ve owned.

With the framwork 12th Gen i7-1280p I cant keep a connection. The dock connects and disconnects every few seconds. I tried all 4 ports on the laptop, updates, rebooted, but to no avail.

When it works for a few seconds, all my peripherals work and the video is outputted to my 1440p monitor.

I’ve tried searching but it seems the TS3 has only been tested working with a Linux OS so far on the 12th gen.

Anyone had any better luck?


Have you tried plugging it directly into the laptop, i.e. with no module inserted? It’s not recommended to do this often because they’re not strain relieved, but it’s a useful troubleshooting step

Same behaviour.

Actually even worse, the external monitor comes on for a split second only. With the USBC module in place, at least it stays for a 10-20 seconds.

So, I thought to try a shorter thunderbolt cable as the one that came with my TS3 was the long one.

the 2.6 ft CableMatters 40gbps cable from Amazon seems to work and now I have a properly functioning dock again. Yay!


I tried a 3ft USB4 cable. That only makes the dock works with peripherals. No display shows up.

So the smaller 2.8(?) ft cable works fine. But anything longer screws up dock functions.

I had similar issues after upgrading to the 12th gen. board with my CalDigit elements dock until I upgraded the kernel. What kernel are you on? I moved to 5.19 and things became pretty reliable.

I’m using windows 11 pro. No linux yet.

I’m sorry I haven’t really used Windows in a long time. I assumed if someone was having issues with a TB dock it had to be on Linux. XD