My Solution to Avoid Fractional Scaling

I’m new to linux, so have been tinkering and learning a lot of new things recently.
When I first got my Framework a few days ago, I set the display to 175% scaling. However, some applications (mainly firefox) was kind of “low resolution” looking, or blurry. Not too bad, but it kinda bothered me. So, I tried a few things and this is my latest solution:

*switched to 100% scaling
*changed cursor size to medium in the accessibility options, within settings
*in appearence settings: set desktop icon size to large, and set dock icon size to 64 (maxed out)
*ran this command suggested by osemec on; a factor of 1.5 fit my liking: gsettings set org.gnome.desktop.interface text-scaling-factor 1.5

Seems to be working good for now! I will see how I like it over the next few days. The only thing I noticed that is a bit out of the ordinary is the 3 window buttons (top right corner) for minimize, maximize, and close, are very small. In all windows. However, this isn’t much of an issue for me at this point because I use keyboard shortcuts to do these things. I also adjust website zoom level via ctrl+ or ctrl- on each website in firefox as I visit. Firefox seems to “remember” my previous zoom setting independently for each website, so websites continue to look how I want them after the initial visit and adjustment. I did this kinda often anyways on firefox so this is nothing new for me.

1 Like