New board not booting

Documenting my woes here, just in case someone else is faced with the same issue. There is one other (very long) thread about a somewhat similar experience, I will keep this dry, technical, and focused on process.

Got my DIY 16, with 64GB Ram and 1TB WD Black also provided by Frame.Work. Everything assembled as per instructions, all contacts fully seated, used an electrostatic mat and grounding bracelet while doing so. On first boot, with midplate closed and inputs installed, no image on screen, no sound from fans. After some sleuthing, left it on for an hour, in case RAM needed to be ‘trained’, nothing happened.

Took everything out, tried one dimm at a time in either bank. After several tries eventually got to boot with only one dimm on bank 1. Got all the way to BIOS, tried to boot from install USB (verified working in both UEFI and legacy modes in a different machine), BIOS would recognize stick was connected but not be able to boot from it.

Went back in, tried swapping dimm on known working bank, no go. Went back to known working dimm, no go. Now I get the power on button blinking (4 secs on, 1 sec off). Contacted support, within five hours they provided me a procedure to reset the mainboard state: with machine connected to AC power, press the intrusion switch 10 times, for 2 seconds each time. Then power on and record video of debug code lights. The result of this was that on the first 12 blinks I get green on everything except blink 6 (touchpad, which makes sense, as midplate is not installed at this point), and then on the final 8 blinks I get 1 blue, 7 green (code 0x80, basic memory test). No screen, power button shows same behavior, fans don’t move. Communicated results to support, waiting to hear back from them.

A few notes: the one time I made it to the BIOS, memory test showed everything was a-ok. I was able to reboot a few times and output detailed info. In the current state, when you plug in to AC, board lights blink red (warning, don’t disconnect anything). However, when you go through the 10 presses eventually they alternate to red/blue. I say eventually because the behavior is not consistent, sometimes 5th press, sometimes later. Finally, just repeated reset procedure and now I get red blinks at positions 6, 7, 8. See here for meaning of basic post lights and bit values for post code section (final 8 blinks).

Hope this helps anyone seeing the same behavior, will update here as I hear back from support. They seem responsive, escalated to L2 fairly quickly when FedEx missed delivering my package and did not contact me to reschedule (not in the US, procedures in this country are different).

3 Likes

Small update
Noticed that HDMI expansion card was in port 5 rather than 2 (put them in while computer was upside down, reference has top facing upwards. Removed all expansion cards, except USB3-C at port 1. Ran reset procedure, powered on. Power button no longer blinks, stays on. More importantly, post code bits now translate to 0x8C, “iFFS transition start”. Tried a second time, got 0x81 “TXT function early initial”.

1 Like

Hi,

Just to clarify:
DIY FW16, 64GB RAM and 1TB WD Black all came direct from Framework?

When you got into the BIOS, what changed to stop it working?

My diagnosis on this one would be its an intermittent problem, resulting in it failing at random points. Could be bad RAM or bad MB. Difficult to diagnose any further due to the intermittent nature of the fault.

Yup, all from FW.
What changed to stop working was I wanted to check if it was a DIMM or bank issue. Check fourth paragraph on OP. I agree, very inconsistent. Is it a DIMM? Is it a bank? Both? Hard to say. Fact is when I went back to known working DIMM in known working bank was never able to boot again, even after reset procedure.

Support got back in touch asking for detailed pics of RAM contacts, full main board, and delivery box (last one specifically looking for evidence of damage). Also suggested using compressed air to clean contacts on main board, so looks like we are zeroing in on a RAM issue.
Took them 11 hours, so guessing pretty slammed right now. Super professional and replies don’t seem canned, rather from someone who looked into what I provided and has a theory of what is going on.

1 Like

I suggest double checking to confirm the RAM DIMMs are all seated properly. Eject them and re-seat them. Check pins are all seated and the lock tabs are fully engaged. Also check that SSD is fully seated. It is possible to only partially seat SSD and be able to set the set screw. Check to make sure the lock tab is fully engaged.

Heard back from support. Asked to pull all expansion modules and SSD, put only one DIMM on slot 0, power cycle using SW1 directly on the board. Rinse, repeat on slot 1. Did that twice, using both available DIMMs. No change in diagnostic lights’ pattern.

1 Like

I’m having similar problems but with my own memory. Both modules work, but only on channel 1 (not channel 0 or 0 & 1). Hoping support can figure this out for us!

Welp, after a few more exhortations to test out one bank at the time without SSD installed, issue got escalated.
They do advise that they have higher volume than usual at escalation, so not counting on hearing back before Monday.
From comment above, mine may not be an unique case. Funky batch? Let’s see what’s next. Support has been super responsive, sometimes more than one person coming back to me. No complaints.

1 Like

I was batch 3, what were you?

I’m hoping it’s something they can resolve easily. I can totally use it for now with “only” 32GB of memory, but I’d like to have the option to use all 64 :slight_smile:

I wish I had other approved memory to test with just to be sure it’s not incompatibility with my BYO ram, but I suspect it’s something else since both sticks work in one of the slots.

I’m on B2. Working out the kinks is reasonable for real early adoption. I’ve been waiting for it since July so I can work through it a few more days or weeks.
I am actually surprised mine is just the second thread on this type of issue. To me the big takehome is that support is on top of things and not giving anyone the run around. For a machine that is supposed to last the better part of a decade and be fixable that is the key issue.

To add: twice now I had different people saying that my case was escalated and yet asking me to do something I had already stated did not work. Several people on the same ticket at the same support level. FW may want to look into their ticketing system. Probably trying to meet timeliness goals, but then of course overworked people will miss previous exchanges on the thread and repeat stuff. If anything a sign that they want to be responsive, just not very efficient.

Hard agree!

I have a 13 11th gen that I’ve loved for the past year or so, and I’ve been pretty happy with it! I’m happy to be able to have laptops I can adapt and upgrade readily, and good support from the manufacturer to do so!

Aaaaand… the board gets RMA’ed, after they looked closely at the board pics. Unclear what that last part means, maybe that there is no obvious damage so best guess is a faulty board?
They do advise the RMA team is experiencing higher than usual volume, so I guess these early batches be finicky.

Hi,
If a board shows no visible, to the eye, damage, one can still use special x-ray machines to take pictures of all layers of the board and work out where the fault lies. Where I work has such a diagnostic machine.

Well, that is for sure beyond the scope of the equipment currently available in my living room. :stuck_out_tongue: Hopefully the new board will be in top shape and they can figure out if they have a production issue or just a bad delivery contractor when they get the original board back.

1 Like

Did they request the board to be sent back before issuing the new one? Not a huge deal, but mine’s usable with one DIMM, and was hoping to actually use it until I can replace it (assuming they RMA mine.)

Also, are you sending just the board, or the whole laptop?

No details yet. Will update when I hear back from FW.

So, already got my UPS shipping label. Old board will be sent back on the same box in which the new one will arrive. Order is confirmed on the website, but no email with tracking information yet.

1 Like

Yeah, I just got an RMA this morning too, so hopefully it won’t be too long for either of us! And hopefully we get boards with no more problems :slight_smile:

My guess is the boards were damaged in transit. Not damaged enough for someone to see with the eye, but damaged enough to cause your problems. For example, simply running over a pot hole in the road can be equivalent to dropping the box from 10 meters.
Quite a good guide for testing delivery boxes is to test them against the MIL / STANAG military standards that covers vibration, shock etc. required for parts delivery from factory to the field. Remember the boxes being delivered are not placed on comfy seats like people are when in the vehicle. Remember how comfortable it is sitting in the back of a pickup truck.
I think it should be tested with 700-800G of shock.
e.g. The non-operational shock requirement is 700G, half-sine, 0.5ms, total 6 shocks,
along all three axes (+/-).
In the frame work packaging, I wonder how much a 700G shock is attenuated when passed though to the motherboard.