New Mainboard installed. Worked for a day, now just a blank screen and fan

I recently replaced my mainboard because I had a water-related issues (the lid came off my water bottle in my bag and soaked my laptop :frowning_face:). I tried to deal with the issue as quickly as possible, but I discovered that I had fried a chip on my mainboard so it was replaced. All other components looked fine, but just to be sure I completely dismantled my laptop, carefully dried everything and reassembled when I got my new mainboard. Everything seemed to be going fine for the first day. I run Windows 11 and was able to restore everything using the bitlocker recovery key. The next day, I had an unexpected shutdown with the bluescreen error (I didn’t catch the message before the screen died, unfortunately).

I’ve attempted to reboot several times using this as a guide (My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on).

  • The power button lights up, I have solid white leds on the side, and the fan is running, but no screen
  • I reseated the ram and both memory cards
  • swapped the memory cards and tried one at a time in each slot

I’m still getting a blank screen with a solid led and only the fan running.
Any ideas?
I’m fairly new to all this and have been enjoying the ability to troubleshoot my own computer issues, but I’ve hit a brick wall.

  • OS - Windows 11
  • 13th gen Framework laptop

Sorry to hear that. I’d try re-seating the display cable, and if you have an external display, connecting to it and seeing if you still have no signal. Are you getting any post codes when you turn the machine on - the lights on the side? They sometimes can help to point in a direction of investigation. I always have to record them in slow motion with my phone to work them out. If the prior steps don’t work, I’d recommend reaching out to Support.

Best of luck, I hope that you are able to get things resolved. Have a great day!