Night Light does not work - 12th gen Manjaro Linux

Hello everyone,

using Redshift or any other similar application does not work, the color temperature does not change.

I’ve searched everywhere i know, sadly i cloud not find an answer/solution to my issue.

Could someone please guide me in a better direction where i could find a solution ?
Does anyone experience a similar Issue ?

Additional Info: Framework 12th gen with the latest Manjaro XFCE/Plasma.

Thank you in advance :slight_smile:

1 Like

For me it does work.
I use the command redshift -O 2500
My distribution is Artix (Arch Linux without Systemd), I use Xorg with the driver modesetting, and KDE/Plasma.
But my laptop is 11th gen.
By any chance, may it be a problem that you are using Wayland and that Reshift supports it poorly?

Yeah, I’ve had issues with night light and wayland too. Maybe try using xorg? - Just as a troubleshooting step.

If it works on xorg and not on wayland, if you have the time of course filing a bug report would help the devs out a lot! :blush:

Type the following command on the terminal, then what message do you see?

$ redshift

Official site: Redshift

Thank you all very much for the quick replies :slight_smile: , you guys are awesome.

Just some short clarifications:

$ redshift
Trying location provider `geoclue2'...
Using provider `geoclue2'.
Using method `randr'.
Waiting for initial location to become available...
Location: XX.xx N, XX.xx E

$ redshift -v -P -O 2400
Brightness: 1.00:1.00
Gamma (Daytime): 1.000, 1.000, 1.000
Gamma (Night): 1.000, 1.000, 1.000
Using method `randr'.
Color temperature: 2400K

Note: redshift.service is enabled and running, and the issue is not to redshift specifically, even changing the gamma values from the system, it does not net any visible change

OK. Here is someone’s redshift config file with Sway (Wayland-based window manager). Perhaps randr doesn’t work on Wayland?

May you check what your Xorg driver is?
The intel one is always more problematic than the modesetting one.

@junaruga → thank you for the Link :slight_smile: , but i’m not using Wayland

@Mapleleaf i don’t have a clear idea how to do that ? Is my assumption correct that i should change from intel to modesetting, if yes then how ? :slight_smile: Thank you in Advance.

One last question: Did anyone with 12th gen has a similar Issue ?

You could try xrandr --listproviders and see what is the value of the last “name” field (should be modesetting).

If it is not modesetting but e.g. intel, you could change it by adding a file /etc/X11/xorg.conf.d/10-primary-gpu.conf containing:

Section "Device"
    Identifier "Device0"
    Driver     "modesetting"

@Mapleleaf thank you for providing the command

$ xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x47 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 5 associated providers: 0 name:modesetting

Ok, in this case I don’t really have any idea…
Could you try with a different Linux distribution? With a bootable USB stick for example?

@Mapleleaf , yes i have tried Ubuntu 22.04 on a live USB and the Integrated “Night Light” works just fine.

So it seems that there is a issue with Manjaro (or Arch) on the 12th gen.

Thank you for all the Help.

1 Like

Perhaps, you can report your issue on the upstream project issues.

1 Like

@junaruga thank you for pointing that out and for the link :wink:

But its not only related to redshift, the Night Color in Manjaro Plasma also does not have an effect:

and even playing with the Gamma sliders it does not have any effect whatsoever.

Hi everyone.

First, thank you again for the replies and the Help.

Second, i have fixed the Issue under Manjaro by using a newer Kernel

Have an awesome time everyone :).


I’m having the same issue and am also on Manjaro. What kernel did you use to fix this issue? Here’s the kernels that I see available in the Manjaro Settings Manager:

Hi @Jason_Axelson, i’ve just used the next one that was not realtime (in my case 5.18.19-3, i am using Manjaro with Plasma Desktop and i asume that you are using XFCE). But that was only my first try, i did not experiment with other kernels.

Please Note: depending on which kernel you use, you may experience some stability issues. For example i have some problems with virtualbox but did’t study the issue in detail to check if the correlation is real or just me doing stuff wrong.

TLDR; there may be stability tradeoffs in switching the kernel.

One last note, in my case i have also disabled the ALS, a bit of an unorganized approach (i don’t know if there is causality/correlation), the night light is an very important feature for me :slight_smile: .

Thanks! I’ll give it a try. I’m also using Manjaro with Plasma Desktop so I’m pretty hopeful!