[RESPONDED] Adjust Display Brightness Fedora 38 (12th Gen)

Hey there,

I’ve just installed a clean Fedora 38 version with a gnome desktop following the given instructions for fedora 38 and fedora 37 on a refurbished Framework 12th Gen.
Unfortunately I can not adjust the display brightness at all. Thats the grub entry that I’ve created by following the instruction

GRUB_CMDLINE_LINUX=“rd.luks.uuid=luks-bce25c9f-0b4d-49bb-aa4c-ba49abbe9acb nomodeset rhgb quiet nvme.noacpi=1 module_blacklist=hid_sensor_hub”

I’ve searched around for some time, but still got no clue what to do. I also installed xbacklight, but no matter what I tell the terminal nothing happens (for example “xbacklight -set 100”)
What’s also unusual is, that I can not activate the “night light” in the display settings. Maybe there is a driver missing, but if so I also couldn’t figure out how to fix that. Any help is appreciated!

What’s the failure mode exactly?

I’m also running Fedora 38, but on a 11th gen machine. What I’ve seen with 38 and (maybe, I can’t remember for sure) with 37 before it, is that sometimes I’ll need to cycle a monitor’s toggle in the Color settings:

before the night light toggle will start having an effect again. Note though that the NL toggle itself never gets disabled:

it is/was just that it wouldn’t take effect even after toggling it off/on, until I cycled the color settings for the monitor.

I think I’ve only seen this with external displays TBH.

One final thing: If you are also using the Sunset to Sunrise option, make sure you have your longitude/latitude set correctly (or have enabled location services - I don’t). To set longitude/latitude manually, I use the dconf tool:

Hi @dimitris and thanks for your extensive answer. My main problem is that I can’t adjust the display brightness, but I think that this and the night light thing are caused by the same problem. So here is what I get when I try to set up the night light:

I also stumbled over a thread where they said its maybe connected to the color profile. But honestly I do not have a clue how I could possibly solve that:

So for sure I can tell that I’m able to see different colors on my screen, but unfortunately thats it. I tried to import standard color profiles , but still get the same error in the night light settings

The settings window shows you’re in a X Windows session, not Wayland. What happens in a Wayland session (which should be the default)?

You should be able to get to a wayland session when logging in, there’s a settings icon or similar IIRC.

1 Like

Why do you think I’m in a X Windows session? (Just asking cause of curiosity)
I checked the window manager and settings is telling me I’m in a wayland session:

I also found this using “screenfetch” (git-link:

So under resolution it says “no X server” but there should be a resolution like 1920x1080 or not?
And maybe a strange question, but can you change the resolution of your display? Mine is stuck at 2256x1504 (according to settings)

I assumed X because your color profile settings designated the monitor as xrandr which is an X thing.

Your About screen shows Wayland, but it also shows software rendering (llvmpipe in screenfetch) which is unexpected and likely to be related to the lack of night light. Also a bigger issue in itself (performance).

Here’s what it looks like on my 11 gen:

Can you try booting without the nomodeset argument? I think that might be preventing the iGPU driver from being loaded/used.

Hi @Leon_Kopka1

Verifying this was done with grubby via the guide and not merely adding in the parameter? So you ran this exactly:

sudo grubby --update-kernel=ALL --args="module_blacklist=hid_sensor_hub"

@Matt_Hartley thank you as well for joining the thread. I ran exactly that line and verified it as well in the grub file (etc/default/grub)

@dimitris I canceled the nomodeset in the grub file. Reinstalled grub2 for UEFI systems (with Bootloading with GRUB2 :: Fedora Docs) and I can fortunately say that its now working. The first boot took some time, but I can adjust the brightness, activate night light and so on

Hope thats it finally and thank you so much again for your help!! Appreciate it!

Happy to try and help. So you should have only needed to run the grubby command, no need to open etc/default/grub at all. I suspect this is where things went wrong.

All that is needed is:

sudo grubby --update-kernel=ALL --args="module_blacklist=hid_sensor_hub"

Anything beyond that such as editing grub manually is a new factor that may mean you now need to manually update grub.

I did notice your quotes look to be ” (slanted quotes, happens when copying from non-Framework sites) vs " (standard quotes using a keyboard)

Let’s cat your grub file again, I want to make sure those quotes are correct.

cat /etc/default/grub

Copy and paste the same line again and let’s make sure those quotes are correct. We do not want ” (slanted), we want ". You can use whichever editor you like to correct the quotes if it’s needed.

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

And reboot.

Why was it in there in the first place? Modesetting is required by the intel graphics driver.

@Matt_Hartley the result looks clean, don’t know where the slanted ones came from. Maybe cause I didn’t pasted as a preformatted text.

[leon@fedora ~]$ cat /etc/default/grub GRUB_TIMEOUT=5 GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)" GRUB_DEFAULT=saved GRUB_DISABLE_SUBMENU=true GRUB_TERMINAL_OUTPUT="console" GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-bce25c9f-0b4d-49bb-aa4c-ba49abbe9acb rhgb quiet nvme.noacpi=1 module_blacklist=hid_sensor_hub" GRUB_DISABLE_RECOVERY="true" GRUB_ENABLE_BLSCFG=true
@mcz unfortunately I dont know. Pretty soon after I installed fedora I used this guide as well: GitHub - smvarela/fedora-postinstall: My personal Fedora post installation guide. Use it at your own risk.
Cause I’m new to Fedora I wanted to get some more user friendly insides. But I just picked some things out there, like gnome-tweaks

If you boot without modesetting, the Intel graphics driver bails out (does not load) and you’re left without graphics acceleration or any other driver feature. This is should only ever be required for weird cases where the GPU acts up or random bugs prevent the system from working otherwise. But glad it’s working again.

On a clean, brand new install of Fedora (which may be worth it at this point) - the only guide you should use is ours.

Anything outside of this is likely going to create new issues.