No video (internal or external) on new FW13 AMD DIY

(yes, I’ve opened a support ticket already, but I know they’re very busy so thought I’d also post here)

My laptop arrived yesterday and the display does not work. I’ve tried reconnecting the internal display connector to no avail. The blink code is wgggggggggggrrbggbbbbb (w=white, g=green, r=red, b=blue) which if I understand correctly means the “Internal display initialized OK” diagnostic is NOT ok. Tried plugging the laptop into an HDMI monitor (via a USB-C to HDMI dongle I used with my MacBook) and there was no video output.

Does anyone here have suggestions for further diagnosing this issue while I wait for support?

Third party parts used:

  • G.Skill Ripjaws 2x16GB DDR5-5600 (F5-5600S4040A16GX2-RS). Tried one stick at a time as well, with no difference, and the blink code suggests the ram test passes.
  • Solidigm P44 Pro 2TB SSD. Based on another post I think the post code is indicating no boot device, which would make sense since I haven’t installed the OS yet.

weird… you can always try seating only one of the two ddr stick in there. also keep in mind that video out only works on three of the four ports on AMD. avoid bottom left port for video.

I’ll just note that I had a similar situation with only the last of the initial 12 diagnostic lights being red (your next “red” is probably actually the orange that separates the sets of blinks). For me it was reseating the display connector that was necessary, so just be sure to try that also. You say you tried an external display so maybe that’s not your issue but it’s simple and worth trying to be sure.