Not actually sleeping - Windows 10 and 11

When I close the lid, the computer should sleep.
More to the point, when I press the freaking sleep button (power button configured to sleep, or start/power/sleep), it should go to sleep.
Any other laptop I’ve ever owned, this is what it does.

Framework doesn’t. It just blanks the screen and locks the desktop. :persevere: It’s still consuming power (5-20 watts). It instantly wakes up if I as much as breathe on it, cheerily as if “this is what you want, right?”. No! I want it to be asleep… consuming 1-2 watts… able to stay like that for multiple days on battery at a time.

Instead, if I close it and leave it overnight, the thing goes to hibernate instead… fully powered off, going through POST (5-10 seconds) and reload (2-3 seconds) before login screen. Great, that’s fast for what it’s doing (not sleep as I requested)… slow for what I asked it to do (not what it did). Windows 11 completely hides the fact that it goes to hibernate (there’s no hibernate timer in power options, but at least Windows 10 admits it’s real).

I’ve heard some murmuring that “that’s just how it is now”, and in effect, “it just stays on all the time, and sleep is dead”. The hell kind of funhouse-mirror world is that? Up is down, more power consumption is new?

Please, god, tell me there’s some simple setting I’m missing…


13 posts were merged into an existing topic: High Battery Drain During Suspend (Windows edition)

Interesting case study on how bad the search function is on this forum, because of course I searched before posting… and didn’t find anything relevant except Linux complaints and other marginally-relevant threads.

Would’ve been nice if that thread showed up. Oh well…

(Same with my rant about the awful touchpad, too…)

Yes, but here and in that other thread, you’re phrasing it as “per hour”, which is… which are… words that I don’t think you know how you’re misusing (even now). The confusion between watts and watt-hours is utterly pervasive (especially in the EV world where it’s all coming out for everyone to see), and I just don’t know how it’s so easily messed up. It’s worse than your/you’re, but the same kind of mistake :joy:

Watt-hours = energy = consumption, “fuel used”
Watts = power = speed, “rate of consumption”

Crappy “modern sleep” chews arse-tons of energy because it allows software to continue running when it’s not wanted.

I believe the disconnect here is that @Matt_Falcon is measuring wall power which includes charging the battery. The experiments posted on the other thread are looking at battery discharge rate away from the wall.

Sorta. I’m trying to factor-out battery charging, which is a steady offset from consumption (it doesn’t fluctuate, so it can easily be excluded).

What I see with “S0” is that consumption is erratic and significantly higher than it should be (5-20w) instead of “go to sleep you freaking idiot, why would I ever need you to be processing stuff in sleep?” (1-2w). It’s not a phone, it doesn’t have an outlet for notifications, and I’m not running a task, so why the heck should the processor still be awake and running when I want it to sleep?

I close the lid, that means “I’m done with the computer for the immediate moment, please stop consuming power and sleep”. It doesn’t mean “stay running just in case I change my mind and want it back within 0.1 seconds”. Having it wake faster from S3 (like a 2017 laptop) would sure as heck be nice.

Hibernate wouldn’t be terrible either, if it would actually POST in 1-2 seconds instead of the 5~8 seconds it seems to take now. I still wouldn’t like the SSD wear that the constant (multiple times a day) hibernate would be causing, vs. just freakin’ going to S3 sleep like normal.

It’s unusual for so many people to pile onto something so technical and under-the-hood, but finding the overwhelming cries of “dear god please let us disable this stupid feature” against so-called “modern sleep” ought to be enough for the powers-that-be to realize it’s an unwanted mode.

eh. I give the computer tons of idle time (like here, now, writing this). Most of what the computer does in its waking hours is idle time in effect - very low workload. Problem is, it chooses extremely poor times to do its updates (tries to find “when I’m not looking” times - and if I’m not looking, the computer should be sleeping).

yup. All of this. The need isn’t there (imho) and the implementation is dodgy af. Really don’t think my computer should be chewing through a fixed % of battery before thinking “shruggy.gif, I’ll go to hibernate now”, which could be 30mins or 3 hours.

I’m still open to giving it more of a test, especially given the data in that other thread showing how little it CAN consume…

I have the same issue – when plugged in, the laptop will not go to sleep. It just sits there with a blank screen, fully powered on. When unplugged, seems to work as expected.

Did you have any luck with this @Matt_Falcon ? The other thread is about high power consumption when sleeping. I can’t even get the thing to sleep.

I’ve kinda grown to live with it in the time since. It’s the second worst problem with the computer (first worst: the awful touchpad / sliding clicks / imprecise mousing).

I’ve come to understand Modern Standby this way: “I’ll do what I want, and you can’t do anything to stop me or hold anything I do accountable”. When you “go to sleep” (close the lid), it marks down what battery level you’re at. If it goes below a fixed budget of percentage (that is, say it loses 5% of capacity, goes from 75% to 70% while “asleep”), it’ll immediately drop to hibernate. At any time in between there, though, it may be fully awake, may be daydreaming/low power mode, may be updating, may be whatever. Thus, one time I was able to close the lid with a queued print job, bring it to the USB printer, plug in the printer, and the print popped-out with the computer “asleep”… and yet, another time I tried that, it didn’t (but it popped-out the moment I opened the lid).

Just leads me to finding that Modern Standby is incredibly opaque and user-hostile. I find that, in practice, it leads to the computer randomly putting itself in hibernate throughout a day (I think I average 2.5 hibernates a day or so at this point), which burns through SSD life and takes about 30-45 seconds to “wake” (including the incredibly long POST time).

When plugged in, though, I’ve found it to eventually fully charge, and eventually settle itself to a low power mode (trickling a few watts). It no longer seems to blast its fans full tilt any time it’s plugged-in/closed.

I also still solely power the laptop using solar power from a battery bank - and use it regularly every day for my daily personal stuff. I do split the load between my other Dell laptop, though. Its touchpad is a hundred times better (even if it’s crippled by a lack of drivers, thus lack of 2-finger scrolling). :slight_smile:

1 Like

Wake from hibernate should not take 30+ seconds. It’s always around 10 for me.

It “should not”, indeed. But it does. About 10 seconds from power-button to “the screen backlight actually turning on”, another 5 seconds at a fully grey screen, 5 seconds at “Framework” POST screen, 5-10 seconds at “Framework” + OS loading swirly, 5 more seconds from there to black screen → login curtain, and finally I can fingerprint and get back in.

Anything less than “time from power-button press to actually being able to log-in” isn’t a full count.

(I might be rounding-up some of those steps, though :thinking: backlight time might be more like 7, POST more like 3, OS more like 7, I dunno… but definitely NOWHERE is a 10-second resume a plausible outcome!

(just counted seconds from button to login) OKAY FINE IT’S MORE LIKE 17 SECONDS :joy:

Still, too darn long and wastes SSD life.

That’s too bad but good to hear you’re at peace with it lol : - )

I’ve been having this problem for as long as I’ve had the Framework. I’m on Windows 11.

Either it WOULD NOT SLEEP even when telling it to (the screen would go dark, then come right back on to the login screen without any input), or, after a longer time, it would be in a hibernate kind of state and I would have to drag it out of the dock to wake it up. I’ve taken various stabs at fixing it without success.

I finally got determined yesterday, and tried everything I could think of or find a mention of, which included updating the BIOS to 3.09, resetting BIOS to “optimal defaults”, and turning off “Link State Power Management” in the power plan.

Unfortunately, it was a very uncontrolled trial and I can’t say for sure which part did the trick, but something worked. I put it to sleep last night, the monitors turned off and stayed off, and when I came back today I woke it up with simple mouse input. FINALLY.

I’m trying to reverse engineer it. I’ve changing back the Windows settings, like Link State Power Management, and that hasn’t caused any problems.

Update: I restarted to check the settings in BIOS (didn’t change anything) and when I got back to Windows the problem was back. I immediately disabled that power plan setting again and that fixed it. Seems likely to be the culprit.

Well, see, you’ve run into the FUN part about Modern Standby: it goes to hibernate not based on a timer (so you can’t predict it), but rather by a “battery burn budget” instead - when you close the lid to sleep, it remembers what % battery you had left, and continues running in “fake sleep” mode, until it burns through its budget (say, it went to sleep at 65% and now it’s 60%) - then it drops to hibernate to prevent further drain.

That’s at least what I’ve been able to determine by behavior & research using powercfg /sleepstudy. I would suggest running powercfg /sleepstudy yourself to see a chart and table of usage/drain/hibernate patterns.

Since Newspeak Standby (pffh “modern” my arse) basically takes away all your power management controls, you really would be best to not change the legacy power plan options - they don’t do much anyway but hurt performance. I would suggest leaving it on “balanced”, but also to change the fixed hibernate timer to “never” (it seems to take random values, like “24325423 minutes”, by default) - set it to 0 to disable. It doesn’t change hibernate behavior, it just allows it to adhere to its “power budget”.

The best place to change power management is the slider under Windows 10’s battery icon:
This actually affects performance & thermals - I leave mine on “Better Battery” all the time unless I’m performing a computational task, then bump it to “best performance” and back after it’s done. That gives me the best battery life/performance balance on every machine I use.

(naturally, like all good things, Windows 11 seems to have removed this power slider - so you now have NO power management options. The best solution to Windows 11 is to install Windows 10, lol)

So, give a sleep study a try! It can’t exactly help the case of it going to hibernate, but it might help explain it at least.

On a different note, though, my work laptop is a newish Dell Precision laptop with that god-awful Newspeak Standby, and it can’t even be disabled using the registry tweak – it just prevents standby altogether. Dell completely removed the ability to go to standard S3 sleep. However, the Framework laptop still has that functionality – though it’s bugged (long POST delay at resume), it’s at least an option - you can try it with the registry tweak to block Newspeak Standby, and it’ll go to S3 sleep instead.

I saw various examples of hibernate in the power settings while I was looking for solutions, but that’s not in my power plan at all, only sleep. I also ran the sleepstudy report and don’t see hibernate in there. I do see options in the power settings for “Best Power Efficiency” vs “Balanced” vs “Best Performance”, it’s just a drop down instead of a slider.

I think I’ll try that registry tweak, sounds promising.

Update again: Oh, NOW I can see hibernate settings, once I switch off the modern standby.

It’s even weirder on my computer, when idling on desktop the power consumption is 4~5W and when closing the lid(set to sleep) it goes to 26W, when opening the lid again it goes back to 4~5W. Quite suspicious

Just a blip while it’s changing state

I have a full battery but I power on from hibernation, which is quicker that a clean start and it can draw 65W for a while.