Not getting USB 3.2 Gen-2 2x2 (20Gb/s) speeds on 13th Gen Intel

Has anyone gotten USB 3.2 Gen-2 2x2 (20Gb/s) performance on the 13th Gen Framework?

Framework 13" Laptop
13th Gen Intel(R) Core™ i7-1370P
Intel Core -2200

I downloaded and applied the latest drivers, and windows 11 Pro is fully updated.

New Crucial X10 Pro USB4 drive with the included cable is only getting around 1000 MB/s read and write speeds, much slower than it should.

CrystalDiskMark 8.0.4 x64 (C) 2007-2021 hiyohiyo
                                  Crystal Dew World
* MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

  SEQ    1MiB (Q=  8, T= 1):  1072.157 MB/s [   1022.5 IOPS] <  7809.48 us>
  RND    4KiB (Q= 32, T=16):   221.513 MB/s [  54080.3 IOPS] <  9310.67 us>

  SEQ    1MiB (Q=  8, T= 1):   993.193 MB/s [    947.2 IOPS] <  8421.89 us>
  RND    4KiB (Q= 32, T=16):   246.376 MB/s [  60150.4 IOPS] <  8459.63 us>

Profile: Peak
   Test: 32 GiB (x5) [F: 1% (21/3726GiB)]
   Mode: [Admin]
   Time: Measure 5 sec / Interval 5 sec 
   Date: 2024/03/14 15:32:20
     OS: Windows 11 Professional [10.0 Build 22631] (x64)

I used the (very disappointing) management tools from Crucial to verify the drive had the latest firmware U1CR1B04

I ran HWiNFO64 which lists both USB v3.2 and USB4 support

Motherboard Model:	Framework FRANMCCP07
Motherboard Chipset:	Intel Alder Lake-P PCH
Motherboard Slots:	1xPCI Express x1, 5xPCI Express x4
PCI Express Ver:		v4.0
USB Ver Supported:	v3.2

Device Name: 			Intel Raptor Lake-P - USB xHCI Controller
Original Device Name: 	Intel Raptor Lake-P - USB xHCI Controller
Device Class: 			USB xHCI Controller
Revision ID: 				0
PCI Address (Bus:Device:Function) Number: 0:13:0
PCI Latency Timer: 		0
Hardware ID: 			PCI\VEN_8086&DEV_A71E&SUBSYS_0003F111&REV_00
USB Version Supported:	3.2

Driver Manufacturer:		Generic USB xHCI Host Controller
Driver Description:		USB xHCI Compliant Host Controller
Driver Provider:			Microsoft
Driver Version:			10.0.22621.2506
Driver Date:				17-Oct-2023

Intel Raptor Lake - Integrated Thunderbolt DMA 0

[Driver Information]
Driver Manufacturer: Generic USB4 Host Router
Driver Description: USB4(TM) Host Router (Microsoft)
Driver Provider: Microsoft
Driver Version: 10.0.22621.2792
Driver Date: 29-Nov-2023
DeviceInstanceId: PCI\VEN_8086&DEV_A73E&SUBSYS_0003F111&REV_00&USB4_MS_CM\3&11583659&0&6A
Location Paths PCIROOT(0)#PCI(0D02)

When I look at benchmarks of the x10 Pro online it should be getting double this performance with USB4. benchmark

Has anyone gotten USB 3.2 Gen-2 2x2 (20Gb/s) performance on the 13th Gen Framework?

Are you performing these tests on battery or while plugged in?

Good question. I am plugged in and the battery is fully charged (well, charged to 80% per the setting in the BIOS.)

Also forgot to ask, have you selected “prefer maximum performance” in settings? If you haven’t, try enabling it and see if it works. If it doesn’t work, trying removing the battery charge limit then seeing what happens.

From the product page it says usb3.2 2x2 which would sugest 2ish GB/s

USB3.2 20gbit support is a bit spotty but I though the intel platform had it. The amd framework definitely doesn’t.

USB4 is only a transport layer, so even if it was usb4 it would have to use something (like pcie or in this case usb3.2) inside the usb4 link to do the storage bit.

That is what I expected, but am only getting half that. I’m wondering if the 13th Gen Framwork doesn’t support it…

Anything else plugged in on that side of the board, dock, 4K monitor?

No, nothing was plugged in, but based on what I read about USB4 that shouldn’t matter… but things don’t always work as designed.

gen 3.2 2x2 is a bit of a bastard child barely anyone uses. It’s so optional not even thunderbolt4 requires it.

You would have probably been better off getting an actual usb4 enclosure and an nvme drive for that price then you could even get around 4gb/s.

Edit: oh dear I underestimated the price, here the 2tb model is 250$, for that price I could get a 40gbit capable usb4 enclosure and a mid tier 2tb nvme ssd. for a few more $ you could even get a garbage tier 4tb one XD.


It actually can matter. You have one thunderbolt 4 controller on each side of the Framework 13 which essentially limits each side to 40gbps of bandwidth. If you have other stuff running on the same side it could easily chew up that bandwidth. Any way no the problem you are facing.

So are you suggesting the Frame.Work’s Thunderbolt4/USB4 doesn’t include USB3.2 2x2? Which is why I’m only getting 1mb/s?

Not how it is implemented by Intel. Not at all.

Anybody read my thread on this? (Details on exact level of support of USB4 ports on 13th gen? - #6 by Ray519)

a) Intel specs their USB4 ports from 13th gen mobile as capable of DP UHBR10 & UHBR20 and USB3 20G (for completeness sake: only natively on the port, not tunneled. DP UHBR would not even fit). But they also say that this requires Hayden Bridge ReTimers and not the same Burnside Bridge ReTimers that were used on the 11th and 12th gen FW mainboards.
FW has not published the mainboard specs for 13th gen on Github, only AMD, 11th and 12th. So we cannot read from there which ReTimers are used. FW has no specific specs for USB-C ports that say it supports USB3 20G or anything more than the 12th gen.

So, check what ReTimers you have. I have found no Intel 13th gen notebook advertising USB3 20G support (or DP UHBRx support). You’d be the first to show that support. If you do not have them, USB3 20G is not supported.

b) the spec version, as always does not guarantee any speed. That is just a grave misunderstanding. It simply refers to a PDF that explains how one could implement USB3 20G. Seeing “USB 3.2” anywhere in NO WAY means USB3 20G speeds. That is why this spec version, just like the many other spec versions like DP 1.4, HDMI 2.1 should never be mentioned anywhere outside of referencing specific details, like quoting the exact wording inside a specific version of the spec PDF.

1 Like

And in what way would that drive be USB4? It is only USB3 20G. No USB4 in sight.

Literally nothing you said refutes anything I said. I stated each controller had a total of 40gbps bandwidth not per port, per controller. So if somehow that is wrong please point me to the decoumentation, I would love to read it.

That is the likely cause. 3.2 2x2 is rare as hell.

Assuming you mean 1gb/s then yeah that is the expected speed for a 10gbit usb3.2 link which is pretty common and I am pretty sure all frameworks have those on all ports.

40gbit “THUNDEBOLT” bandwith per controller/side, in dp alt mode that may be different.

That were supposed to be separate points. Regarding you I only said “not how that works”.

The rest was meant towards the general topic, not you. Forum did not show the multiple empty lines I put in-between to separate both.

Even on the dedicated TB controllers the 40G bandwidth is NEVER shared. Each port can run at 40G. Anything else would break TB or USB4. The only thing that could even be shared are the inputs / bandwidth of the tunnels (so PCIe, USB3, DP).

This was (and is) the way it worked with the external controllers like Intel Maple Ridge. Controller has a single x4 Gen 3 PCIe port it uses for PCIe tunnels (and networking) and USB3 tunnels. Controller has USB2 inputs from the chipset and controller has 2 DP inputs that actually only can achieve their full bandwidth at the same time if each is used on a separate TB-out.

With the CPU-integrated controllers from Intel (starting with 12th gen it seems) things are different.

Intel CPU Specs, here 13th gen

You are right that there is still the notion of a TB/USB4 controller for 2 ports (each side of the FW).
That is what manages the ports and handles TB/USB4 networking / DMA. They also still share the 2 DP inputs, just like with the external controllers.

But PCIe and USB3 are handled way differently. There is one CPU-integrated USB3 controller. It handles all 4 of the TB ports (and CPU only, all other USB ports, including USB2 come from the chipset, not the CPU die). It is directly connected to PCIe inside the CPU.

As mandated by Microsoft for the mandatory USB4 drivers, each USB4 port must have its own PCIe Root Port also “directly attached” to the rest of the PCIe topology. So we no longer have the topology of the external controllers where there is one PCIe connector, then the PCIe bridge inside the port that distributes between controller itself, each TB/USB4 port, integrated USB3 and controller.
Classic/external TB controller PCIe topology

CPU-integrated, Microsoft mandated PCIe topology ("USB 3.2 controller is the CPU-integrated one, USB4 host routers for each side, dedicated TypeC PCIe ports)

Now, what Intel does inside its own CPU does not at all have to be full PCIe. They could hide a lot from us, same as you cannot distinguish the chipset from the CPU even though the chipset basically has to act similarly to a PCIe bridge.
But first rough measurements (1 TB3 NVMe, 1 eGPU) showed no influence between both, no matter in which ports, so the PCIe ports for the USB4 ports probably do not have hidden relations. They likely have a total shared throughput limit. But we already know that that limit is at least 3.9 GiB/s and therefore way higher than the external controllers that are limited by their PCIe x4 Gen 3 connection.
The USB3 controller is connected separately. It probably shares PCIe bandwidth somehwhere with other PCIe devices. Whether that is only the TypeC PCIe ports or all CPU-connected PCIe ports (would include the PEGxx ports for GPU and NVMes) we do not know. Intel themselves have only coarse statements in their specs like at least 3 GiB/s of USB3 bandwidth from the CPU-USB3 controller. And only the at least x4 Gen 3 / 32 GBit/s that TB4 guarantees to be available for a single TB4 port which we already know to be superseeded by the actual implementation.

Sadly, I do not have enough NVMe SSDs and TB/USB4 enclosures to test one in every TB port to check how high the shared limit actually is, but I am sure PCIe bandwidth is not shared per side (anymore).

11th gen CPUs often did not use the USB4 drivers. There are tons of them out there that use the legacy TB drivers and mimick the PCIe Bridge topology of the external controllers, even though there is documentation of Intel Ice Lake (10th gen, integrated TB3 controllers, 4 ports) showing the 4 separate PCIe root ports. It is very possible that those were still limited per side, especially when they appear just like the external controllers. We also know that 11th gen hosts also cannot drive more than the 3.1 GiB/s of PCIe bandwidth per port, just like the external controllers (known from benchmarks with ASM2464 USB4 controller). So it is possible this is just old information that is no longer true for halfway current Intel CPUs.

I was mistaken, I should have said USB 3.2 2x2. Which 20Gb/s, instead of the 10Gb/s I’m seeing.

I did, before I bought the drive. Specifically this part

Which lead me to believe it would get 10Gb/s if the drive supported it.

That user was referring to the USB4 standard. That has the canonical way to do USB with 20GBit/s speeds. Sth. that has been supported since the 11th gen Framework.
And also the reason why USB3 20G is so rare, because it leads to confusion with USB4 20G.
That is why the USB-IF did not even give it a name in its new coordinated naming scheme.
USB 5Gbps = USB3 5Gbps
USB 10Gbps = USB3 10Gbps
USB 20Gbps = always USB4 20Gbps, never USB3 20Gbps
USB 40Gbps = USB4 40Gbps.

Your SSD only supports USB3 20G and lower USB standards.
TB4 and USB4 40G guarantee all lower USB speeds that appear in the canonical list of speeds, no USB3 20G.
The ASM2464 referenced in the post you linked supports USB4 40G and in addition to all the mandatory backwards compatibility also USB3 20G. But that would basically only ever be used if you plug it into a desktop mainboard’s USB3 20G port that does not also support USB4.

Everything else points to the fact that, that starting with 13th gen, Intel mobile CPUs can support USB3 20G in addition to the other USB speeds, IF the manufacturer designs for it. But unless someone actually looks up what ReTimer is soldered to the 13th gen board, we have NO indication that the 13th gen FW was designed for USB3 20G and would ever support USB3 20G speeds (and like I said no other notebook / manufacturer has advertised that they do). And FW never advertised it. With your experience I highly doubt the 13th does or could ever support USB3 20G.

I’ve put in a ticket with support to find out if the Frame Work 13th gen supports 20Gbps. Was hoping a user on here may have had experience with it, but it doesn’t sound like it.