NVME Arch Troubleshooting Kernel Panic

During my last pacman -syu, I got a kernel panic which caused a shutdown. Since then, 9/10 times I try to boot, my framework laptop can’t see my SN750 nvme drive to boot from. The other 1/10 times I make it all the way to Gnome login at which point the kernel panics again.

When I boot from an install media, fdisk -l does not show any nvme entries (boot, root, swap are all missing). However, lspci does list my SN750 nvme drive.

I see most threads about solving kernel panics involve at least mounting the root filesystem. However, since I can’t do that, does anyone have ideas on how to continue troubleshooting?

I’ve removed and reseated the drive to no change, but I don’t have another computer to test the drive in.

1 Like

Additionally, sometimes during a reboot I’ll get stuck at the framework logo and the fans will go crazy, the laptop gets super hot.

Agh this sounds like an issue I’ve run into with nvme drives before on Linux. On my desktop, I dual boot windows and manjaro. One day, my nvme game drive just unmounted out of nowhere and nothing could find it again (though I don’t think I looked on lspci since I didn’t know what I was doing). I wish I could find the page that helped me, but I remember I had to change some flag in my grub config file to fix it. If you look up “linux nvme issues” I’m sure you’ll find it.

1 Like

Just bumping this thread to share that Framework sent me a new nvme drive at no cost and after installing the same image on it, i no longer have kernel panic issues. Thanks Framework! I will be sending back the old drive.

1 Like

I only opened my laptop to install the nvme initially, and it worked fine for more than a month. So I don’t think electrostatic discharge. Mine specifically was panicking upon writing to the drive. I could get all the way to Gnome and let it sit for ~30mins, then panic as soon as something tried to write.

It’s totally possible. Though it didn’t initially happen immediately after an update. That was my first hypothesis, but I wasn’t ever able to update the packages on my bad drive due to kernel panics everytime it tried to write. So if I was somehow stuck with a bad package, i couldn’t repair. Additionally, when I booted from an install USB, downloaded nvme-cli and futzed around with it (including chrooting into the nvme), i got the kernel panic again when writing to the drive. I doubt I will have anything useful to share back in this thread, and will chalk it up to either bad hardware or extremely unlucky misconfiguration by me. Either way, I’m super happy with Framework’s handling of the situation. Makes me feel good that I spent a premium on a new laptop from a new company and they aren’t just like, welp, you’re SOL buy another one.