Plugable UD-CAM with Frameworks 13 Intel i7-1360P

I’m attempting to use a Plugable UD-CAM with Frameworks 13 Intel i7-1360P. The UD-CAM is listed in the Framework Community Forum as being compatible. However, when connecting the Framework to UD-CAM, the dock continuously loops in a connect/disconnect cycle, and there is no video output.

Is the Plugable UD-CAM incompatible with Framework 13?

I don’t have any specific experience with that hub, but it doesn’t look like there should be compatibility issues off of what information is publicly available.

What do you have plugged into the hub (and specific monitor)? Are you using a cable rated for the speed and power delivery between the hub and your laptop (e.g. the one which came with the hub)?

Have you tried connecting the hub with no peripherals plugged in? If it works in that case, try plugging in one peripheral at a time to see if anything suddenly causes problems.

What OS are you using?

Also, and this might sound stupid, but double-check that there is nothing in the ports or cable on either end of the host connection to the hub. Debris could cause some behavior like this with other laptops/hubs in my experience.

1 Like
  1. The monitor is a Dell U2415. The monitor has worked with the UD-CAM with a Dell XPS 13 9350 and a Surface Pro 7 I-5.
  2. I’m using the cable that came with the UD-CAM.
  3. I have tried connecting with no peripherals plugged in, but the connection still does not work
  4. The OS is Windows 11 Pro.
  5. The connection works with the Surface Pro 7, so I don’t think it’s debris. I’ve also tested the connection by plugging the cable directly into the USB-C port of the Framework without the expansion card, but the results are the same.

Thanks for the detailed reply. I don’t have my FW yet to dig into UEFI settings or anything (and mine will be AMD anyway), but maybe someone else who has experience with one can chime in.

Is there anything showing in the Windows Event Viewer when you plug the hub in? Can you post the event details, if so?

Thanks for the response. I’ll check the Event Viewer and let you know.

The problem occurs when the UD-CAM USB-C cable is plugged into the Framework even when no peripherals are attached to the UD-CAM. The power source for the Framework rapidly switches back and forth between the UD-CAM and the laptop battery.

The event log shows the following:

  • System

    • Provider

    [ Name] Microsoft-Windows-UserModePowerService
    [ Guid] {ce8dee0b-d539-4000-b0f8-77bed049c590}

    EventID 12

    Version 0

    Level 4

    Task 10

    Opcode 0

    Keywords 0x4000000000000000

    • TimeCreated

    [ SystemTime] 2023-08-24T17:15:38.2593038Z

    EventRecordID 54418


    • Execution

    [ ProcessID] 1820
    [ ThreadID] 22104

    Channel System

    Computer Framework

    • Security

    [ UserID] S-1-5-18

  • EventData

    ProcessPath C:\Windows\System32\WUDFHost.exe
    ProcessPid 1500
    OldSchemeGuid {381b4222-f694-41f0-9685-ff5bb260df2e}
    NewSchemeGuid {381b4222-f694-41f0-9685-ff5bb260df2e}

The UD-CAM works fine when attached to my Surface Pro 7, so I don’t think it is the cable or any peripheral connected to the UD-CAM.

Thanks in advance for your assistance.

Hi Steve,

It’s not a slam-dunk, but the event you pasted might be somewhat related. There are numerous reports online of people having issues with Intel laptops and peripherals including docking stations and VR headsets cycling (usually on a 1/minute basis, though, whereas your complaint seems to be more frequent than that?). The usual recommendations involve making sure that Windows uses the High Performance power plan while on AC power, and then changing the USB Sleep settings for that power plan to never sleep, and potentially using the local group policy editor to force the power plan to the High Performance plan.

I am not sure if this would resolve your problem, so apologies if it’s a miss. Making sure that the firmware of both devices is up to date and also that the latest DisplayLink driver is installed would also be things I would try as well, then probably going to Plugable and/or Framework support would be next.

1 Like

Just an update on this issue. I’ve been working with Plugable tech support to find a solution. They suggested using a Thunderbolt 3 cable instead of the cable provided with the UD-CAM. I’ve also tried plugging the cable directly into the Framework USB-C port, bypassing the expansion card. Neither has solved the problem. It seems the problem is related to power delivery, as it occurs even when no downstream peripherals are attached to the UD-CAM.

The UD-CAM works perfectly fine with both my Surface Pro 7 and a Dell XPS-13 9250, so it seems it is a problem with the Framework itself. Perhaps it will take a firmware update for the Framework to address the problem.