Power Button phantom presses

My power button has suddenly started acting up. It keeps sending phantom signals to the laptop (Batch 6 DIY, i7-1165G7). It was working fine for the first week.

While in the OS (Ubuntu or Fedora), the Power Off prompt will keep appearing; sometimes in very quick succession. I’ve since changed the behavior so the button doesn’t do anything on press.

The one time I tried to restart to see if that would solve the issue was even worse because the laptop had a hard time getting past grub since the power button kept.

It seems to be something to do with moving/handling the laptop and it’s stable when left on a desk. So I imagine it’s some kind of hardware thing. I’d go in and check but I can’t even power off the laptop properly (since it keeps powering back up).

Wanted to check here first to see if it’s okay to go under the hood while it’s still got power or if that’s a bad idea. Plus any other suggestions people might have. I couldn’t find any similar threads yet.

If you can get into the UEFI settings, you can connect A/C power, disconnect the battery (in the settings), and “Exit saving changes”. This setting shouldn’t reset until you plug A/C power in, so you should be able to safely pull the A/C power (which should fully kill power to the laptop) and then investigate inside.

As for the original problem, I’d look into reseating the input cable.

1 Like

Oh, awesome did not know about that setting. Thank you.

I was able to disconnect the battery. And it seems like it’s not turning on. Won’t be able to open it up until later today but at least the laptop’s not turning on and off for now.

Okay, all solved!

When I opened it up, I found this:

One of the rubber wifi-cable routers had managed to rip itself off the mainboard and onto the input cover. Put the router back into place and it seems to have fixed everything.

My best guess is when I opened it the first time, I pulled the cover off from the top right corner rather than the bottom right. The blue MODULE plastic bit on the ribbon might have caught the router and unseated it. Thanks so much for the tip @Chiraag_Nataraj.


Interesting. I’m wondering, could it be that all that sudden power loss issues a lot of people experienced are actually caused by a power button that just silently stuck for >15 seconds and caused forced power off :thinking:

1 Like

It’s a worth a check for anyone experiencing issues, especially given how easy it is to open up. And for me at least, pretty easy to diagnose.

1 Like