Power Button - No Click

My power button never had a “Tactile Click” to it when I pushed it.
Also, I would have to push it deeper that I expected in order to turn on the laptop. When a friend received a framework, we noted he had a click!
Upon inspection inside, we found that a tack-weld was broken on the metal Tee-Bracket that holds a small rivet (behind the power button.) With a little crazy glue the problem was solved. I reported this to framework, and expect that a proper Tee-Bracket will be forth coming to replace the temporarily repaired one.
So glad I could effect the repair on my own and not have to send it back the mfg!!

1 Like

@Randy_V, Did you install a wireless card in yours? I noticed that the antenna cables could end up obstructing the power button if shifted… maybe have a look.


Not no click, but unit will not turn on, power button not illuminate, fans ramp up to full and no boot. Working with support, but no resolution yet. Will randomly start up if you keep trying. Have been talking to support tried reseating swapping RAM, clearing CMOS, etcetera per customer support. For some reason customer support only answers in the middle of the night (east coast). Right now I have a real expensive desk ornament (Pro prebuilt, i7 1185) Have been working with support since Saturday, Currently problem has been “passed on to the engineers”

Update: Troubleshooting w/ nrp was unsuccessful, yesterday (9/23/21 they started the process of sending me a replacement. A++ on customer service, and I was very impressed with the layout and serviceability inside the unit!

This Framework pc i received yesterday has exactly the same symptom described by the first poster above:

The power button has no click when pushed, and the pc does not start at all, never ever. The power indicator on right side has never lit up in any color.

Do other owners hear or feel a click?
Any suggestions for this pc?, other than returning it.

I have already done the following:

  • fully assembled the pc components twice
  • tried all the fixes and/or issue-spotting alluded to in the above posts
  • tested the wall’s electric outlet
  • checked the electric wire connections, from pc to adapter, and then to wall
  • tried a different electric-power expansion card, and a different bay

Try carefully removing the RTC battery:

Do other owners hear or feel a click?, when pressing the power button.

@Doug_H yes, there is a definite click on the power button on my machine.

Thank you to “RandomUser” and “lbkNhubert”.

So, because all the working PCs’ power buttons give a click, and this pc does not,
that issue is the one that needs to be focused on.
Any suggestions?

I have already done a troubling amount of work regarding this pc.

There should be a audible and tactile click.
When mine did not, I pulled the ‘tee shaped bracket’ under the power button and found that the small rivet / pin that the power button pushes against had a failed tac weld. When you open the PC and look in the area of the power switch you will see a tee shaped bracket. If you look close you will see that the power button pushes on a rivet / pin that should be tack welded to it.
If the weld has failed and the pin remains ‘down’, perhaps the switch cannot reset to allow for a start.

My fix until a new switch came: I positioned the pin on the tee bracket to where it belonged and used fast dry super glue and a pinch of baking soda as a weld. I was back running in 15 min. NOTE: make sure not to conduct this repair with the bracket in the PC as the mix of glue and baking soda will dry almost instantly and it only takes a tiny amount of glue.