Preventing Hibernation

I have a 12th gen Framework running Windows 11. Currently, if I leave my laptop in a sleep state, then when I come back to it I will find that it has completely powered off (hibernated). I find this behavior to be undesirable. I want to be able to quickly resume work on my laptop after having left it closed in my bag for a few hours. This seems to happen regardless of the charge percentage. Sometimes I will put it in my bag, nearly full on charge, and then come back to it just a few hours later and find that it has fully hibernated. (And then when it boots up, the battery will report a still nearly full charge, say 85 percent. So I don’t think it’s sleeping until the last possible second, and then hibernating when it has no other choice due to a low battery, which is the sort of behavior I would have expected.)

This is particularly annoying for me since I have a dual boot configuration that I’m still tinkering with, so on wake up it frequently boots into Linux when what I actually want is to boot back into Windows. My dual boot configuration is a topic for another thread.

For this thread, I would like to know what I have to do to disable hibernation, or at least change something so it stays in a sleep state for much longer. And I wonder, does this issue stem from the new Modern Standby I’ve been hearing so much about? Thanks for your help.

I know I’ve seen this talked about in a thread on the forum before, but I can’t find it now after some cursory searching. That said, your issue may have to do with window’s “Hibernate after” behavior, where there is an advanced power setting that will cause your laptop to go into hibernate after a certain amount of time has passed with it in sleep mode (see Microsoft Support post here). I think that it was also confirmed that there was a hidden feature of windows too, that would cause the same switch to hibernation after the battery percentage had dropped about 5% from what it was when the laptop was put into sleep? Hopefully someone else can find the forum thread and link it here.

1 Like

StandbyBudgetPercent is what you’re after. The default is sleep 5%…then trigger hibernate.

Change it to 50% or more if you want…if you don’t have any DP / HDMI / USBA expansion cards.


Thanks for sharing that post. You mentioned expansion cards. Are DP / HDMI / USBA expansion cards prone to consuming a lot of energy during sleep?

I’m going to try adjusting my standby budget from 5 percent (which I believe is the default) to 10 percent. I’ll post with an update later to see if this has improved things.

The command to do this is
powercfg /setdcvalueindex scheme_current sub_presence standbybudgetpercent 10

Yeah: High Battery Drain During Suspend (Windows edition)

I switched it all off. With a fast NVMe it’s now either on or off. Not like it takes 2 minutes to reboot.

I’m having the same issue and so is another frameworker, let us know if this helps. Thanks!

Unfortunately increasing the budget didn’t change much. I can still close the laptop at noon or so, and then open it back up that evening and it will be fully powered down.

I don’t think modern standby is saving me any time if it means I have to do a full boot every time I open my laptop. In fact, I’m pretty sure it’s costing me a lot more time to do that then it would be to simply update windows once a month while I’m sitting in front of the computer.

@Jason_Dagless What do you mean you turned it all off?

Are you saying you have modern standby disabled? Does that mean you now have access to traditional sleep mode? I kind of miss traditional sleep/standby at this point.

Yeah no sleep, no fast start and no hibernation. Ijust saw all you guys fretting over it like it was 2003 and just decided on or off is all you need when you have 6900MBps at your disposal. :grinning: