Problems with USB

This might be a long shot but I might as well try. I am attempting to utilize the serial monitor in Arduino to communicate over USB with a LoRa development board. When I try to start the serial monitor in Arduino it says “Board at /dev/ttyUSB0 is not available”. However I noticed when I first plug in the board I am able to connect for about 2 seconds before it drops the connection. I’m pretty sure this is a Linux specific or possibly a hardware issue as the board works just fine on a Windows machine.
So far I have tried:

  • Changing permissions per a method I found on Arduinos website that was a specific work around for linux.
  • Trying different cables (USB-C/USB-C and USB-A/USB-C)
  • adding custom rules to /etc/udev/rules.d

I’m kind of at a loss at this point. I previously had a similar issue when trying to connect a debugger but was able to fix that by adding custom USB permissions.

EDIT: I think I may have found the working around. It seems that a program called brltty (used for braille screens) was the culprit. When I would connect the board it would be assigned to ttyUSB0 but then brltty would swoop in and disconnect the CP210x serial adapter so it could use ttyUSB0. I tried to remove brltty but because Pop!_OS is dependent on it I could not. In the end I had to change /usr/lib/udev/rules.d/85-brltty.rules to /usr/lib/udev/rules.d/85-brltty.rules.disabled. The devices now stays connected but my auto brightness seems to be a bit wacky so I might have to turn that off.

1 Like