[RESPONDED] Framework 13 AMD problem: USB & bluetooth stopped working in Arch Linux after a week unplugged

Hello! I’m having a weird issue with my Framework 13 AMD running Arch Linux. After leaving the system unused and unplugged for a week, USB and Bluetooth stopped working, but only in Arch Linux – Windows 11 is fine.

  • Specifically, I’m trying to use a wireless Logitech keyboard and mouse, each with separate USB dongles; they are not connected via Bluetooth.
  • The two dongles are plugged into my Dell monitor, which is connected via USB-C to my laptop.
  • This configuration worked fine until I left the system unused and turned off for a week. It still works without issue in Windows 11. The same hardware works fine with my MacBook Pro M3.
  • I am running the latest BIOS (3.05). The issue first appeared while running kernel 6.9.1, and has persisted since upgrading to kernel 6.9.5. The same problem occurs in kernel 6.6.34 LTS.
  • I tried resetting the BIOS settings.
  • I also tried using the “disconnect battery” option in the BIOS, then leaving the system off for 20 minutes.
  • Based on other related reports, I also tried rebuilding my initrd without Bluetooth modules. This did not help.
  • I tried using a cheap USB wireless mouse instead, which also didn’t work. I also tried without success to use the Logitech mouse and keyboard with a separate USB-C hub without connecting my monitor. Notably my laptop’s webcam also no longer works, suggesting something is wrong with the entire USB subsystem.

dmesg shows voluminous output related to Bluetooth and USB repeatedly resetting. While the system is running, the following messages are logged approximately every three seconds:

[  885.538317] usb 1-1: USB disconnect, device number 8
[  885.656405] usb 1-4: USB disconnect, device number 9
[  885.657116] usb 1-5: USB disconnect, device number 10
[  885.678149] Bluetooth: hci0: sending frame failed (-19)
[  885.678166] Bluetooth: hci0: Failed to send wmt patch dwnld (-19)
[  885.678213] Bluetooth: hci0: Failed to set up firmware (-19)
[  885.678218] Bluetooth: hci0: HCI Enhanced Setup Synchronous Connection command is advertised, but not supported.
[  885.715560] usb 3-1: USB disconnect, device number 88
[  886.894948] hub 1-0:1.0: USB hub found
[  886.894979] hub 1-0:1.0: 5 ports detected
[  886.899970] usb usb1: authorized to connect
[  886.900266] hub 2-0:1.0: USB hub found
[  886.900278] hub 2-0:1.0: 2 ports detected
[  886.902100] usb usb2: authorized to connect
[  886.961595] hub 3-0:1.0: USB hub found
[  886.961628] hub 3-0:1.0: 1 port detected
[  886.963287] usb usb3: authorized to connect
[  886.963476] hub 4-0:1.0: USB hub found
[  886.963496] hub 4-0:1.0: 1 port detected
[  886.964434] usb usb4: authorized to connect
[  886.978318] hub 5-0:1.0: USB hub found
[  886.978398] hub 5-0:1.0: 1 port detected
[  886.980133] usb usb5: authorized to connect
[  886.980451] hub 6-0:1.0: USB hub found
[  886.980493] hub 6-0:1.0: 1 port detected
[  886.983226] usb usb6: authorized to connect
[  886.995198] hub 7-0:1.0: USB hub found
[  886.995247] hub 7-0:1.0: 1 port detected
[  886.997039] usb usb7: authorized to connect
[  886.997369] hub 8-0:1.0: USB hub found
[  886.997410] hub 8-0:1.0: 1 port detected
[  886.999739] usb usb8: authorized to connect
[  887.044805] usb 1-1: new full-speed USB device number 11 using xhci_hcd
[  887.111466] usb 3-1: new high-speed USB device number 89 using xhci_hcd
[  887.222579] usb 1-1: New USB device found, idVendor=32ac, idProduct=0002, bcdDevice= 0.00
[  887.222590] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  887.222594] usb 1-1: Product: HDMI Expansion Card
[  887.222597] usb 1-1: Manufacturer: Framework
[  887.222601] usb 1-1: SerialNumber: 11AD1D00B21A3F111B0A0B00
[  887.282581] usb 3-1: New USB device found, idVendor=0bda, idProduct=5634, bcdDevice= 0.21
[  887.282591] usb 3-1: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[  887.282596] usb 3-1: Product: Laptop Camera
[  887.282599] usb 3-1: Manufacturer: Generic
[  887.282602] usb 3-1: SerialNumber: 200901010001
[  887.285749] hid-generic 0003:32AC:0002.01C7: hiddev96,hidraw1: USB HID v1.11 Device [Framework HDMI Expansion Card] on usb-0000:c1:00.3-1/input1
[  887.294352] usb 3-1: Found UVC 1.00 device Laptop Camera (0bda:5634)
[  887.411450] usb 1-4: new full-speed USB device number 12 using xhci_hcd
[  887.583529] usb 1-4: New USB device found, idVendor=27c6, idProduct=609c, bcdDevice= 1.00
[  887.583535] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  887.583537] usb 1-4: Product: Goodix USB2.0 MISC
[  887.583538] usb 1-4: Manufacturer: Goodix Technology Co., Ltd.
[  887.583540] usb 1-4: SerialNumber: UIDC5FFF269_XXXX_MOC_B0
[  887.714775] usb 1-5: new high-speed USB device number 13 using xhci_hcd
[  887.858566] usb 1-5: New USB device found, idVendor=0e8d, idProduct=e616, bcdDevice= 1.00
[  887.858576] usb 1-5: New USB device strings: Mfr=5, Product=6, SerialNumber=7
[  887.858581] usb 1-5: Product: Wireless_Device
[  887.858584] usb 1-5: Manufacturer: MediaTek Inc.
[  887.858587] usb 1-5: SerialNumber: 000000000

Mashing keys on my Logitech wireless keyboard while its dongle is active leads to these errors:

Jun 18 10:07:18 mango kernel: logitech-djreceiver 0003:046D:C52B.003E: logi_dj_probe: logi_dj_recv_switch_to_dj_mode returned error:-19
Jun 18 10:07:24 mango kernel: logitech-djreceiver 0003:046D:C52B.0047: can't resubmit intr, 0000:c3:00.3-1.3/input2, status -19

Does anyone have any idea how to fix this?

Hi @Jeff_Wintersinger, Welcome to the community :slight_smile:

can you check Ubuntu 22.04 live see if usb and bluetooth is working in a 6.5 kernel?

cheers! :slight_smile:

Hi, @Loell_Framework. Thank you for your help! I haven’t tried the Ubuntu 22.04 config, but I tried a Ubuntu 24.04 live system booted from the Ubuntu installer on a USB flash drive with a 6.8 kernel, which worked. I also tried a number of additional troubleshooting steps, which narrow the scope of the issue.

In the “broken” config below, all USB devices continuously reset every 2.5 seconds or so, and so no USB device is usable.

  • Working: Arch installer 2024.06.01 with kernel 6.9.3 and linux-firmware 20240510 booted from USB flash drive. Here is the dmesg output and pacman -Q output.
  • Broken: existing Arch installation. I installed exactly the same kernel, linux-firmware, and amd-ucode versions as used in the Arch installer. Here is the dmesg output and pacman -Q output.

Points of interest:

  • In the “working” dmesg, there’s a message about “Unpatched return thunk in use. This should not happen!” This error does not occur in the “broken” dmesg.
  • In the “working” Arch installer, the system has booted successfully by 48 seconds in dmesg. Nothing else happens until I manually connect to my wifi network (around 150 seconds) and plug in my wireless keyboard and mouse dongles (around 275 seconds). Both the wireless keyboard and mouse work. No errors are produced in dmesg by these operations.
  • In the “broken” install, the USB subsystem initializes around 0.74 s with the various “USB hub found” messages. This is followed by several “USB disconnect” messages starting around 4.4 seconds, and by 5.78 seconds, the system starts a continuous loop of having USB devices disconnect and then be reinitialized. This behaviour will continue indefinitely as long as the system remains on, completing a USB disconnect/reinitialize cycle every three seconds or so. This behaviour is with no interaction from me as the user, and with no external devices plugged into the laptop. As expected given the dmesg errors, USB devices (wireless mouse & keyboard, flash drives) do not work.
  • In the “broken” install, I disabled any unnecessary systemd units (e.g., bluetooth, NetworkManager, power-profile-daemon).

What could differ between the Arch installer environment and my existing Arch install to explain this behaviour?

Problem solved: I reinstalled Arch. I have no idea what unholy nonsense transpired in my other installation to cause USB to fail, especially given that the installation was only six months old and I updated it regularly, and I left /boot and /home untouched when reinstalling.