[RESOLVED] Doesn't turn on. Get files from SSD?

Dear community,

I left my Ubuntu Framework laptop 13 (13th Gen Intel) on sleep (deep sleep) overnight. Now it doesn’t turn on anymore. The power button doesn’t light up. The side LED blinks GG R GGGGGG RR GG R GGGGGGGG. (G=green, R=red)
I already contacted support since the guide doesn’t help.

Since I need to resume work ASAP, I would like to pull the files that are still on my SSD.
Question: Can I take out the SSD and connect it via some SSD connector to use it as external drive from another computer? Or could there be an issue e.g. because some things are locked, protected, or in a certain state (due to the sleep)?

Got the files now.

Thanks a lot for your time!


With the machine unplugged, try holding down the power button for 30 seconds - I think that is longer than strictly necessary. Then plug the machine in, wait a minute, and try to power it on.

If that doesn’t work, try re-seating the ram, or trying to boot with one stick at a time. See reference here: My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on

What generation are you on? If 11th and nothing else works, you could try resetting the mainboard - be careful, the rtc battery holder is very fragile: Fully Resetting the Mainboard State - Framework Guides

Finally, you should be able to pull the ssd and use it in another machine, but first I’d try to get your current one up and running.

Good luck, I hope that you are able to get things sorted out.



Is it an 11 gen Model?

i habe replaced the RTC battery or CMOS/BIOS battery in mine an don´t have any trubbel since.

But when i tryed to replace it i broke my Battery Holder so i head to solder a new one in.

Long story short reatch out to support.

Hope they can Help you.

I have a 13th Gen Intel @lbkNhubert @Ian_Thomas

For that on I think that disconnecting the battery while disconnected from power will reset the board. Disconnect it, let it sit for a minute, reconnect it - carefully, the pins there are fragile too, and see if that resolves the issue.

I assume that you have tried to plug it in, let it sit for several minutes, then try to power on? This would be in case the main battery was fully run down.

Thank you for your help. I tried everything you suggested except resetting the mainboard.

If the mainboard reset doesn’t help, I would reach out to Support.

It is an emergency and you need to access the files then yeah just yank the SSD out and put it in an external enclosure. That’ll do it. Needless to say you need another computer until your framework is fixed


@Nixingit Unfortunately the SSD is not recognized by my Windows computer. So the drive could be the problem.

Google is your friend. You need some drivers on the Windows machine. Or install VirtualBox on the Windows machine and put in Ubuntu on that and then read the SSD. Try searching for ext4 driver for windows 10 or zfs or whatever file system you’re rocking on the SSD.

1 Like

Does it boot from a live USB?

@Nixingit I already did that. The problem is that the disk is not even properly recognized in Disk Managment, and initializing it apparently erases all data. I used Paragon’s software successfully on another device, but it couldn’t detect the SSD.

The SSD used a file system supported by Paragon?

Is your drive encrypted?

@MJ1 It has Ubuntu on it so it must be ext-something I believe. I also tried reading it with an Ubuntu computer - no success however.

@sciencewhiz I don’t think so. I can’t remember doing anything to encrypt it, nor did I mean to.

Did you look at it with Gparted, or other linux partition manager?
Do you have backups for any important files?

Really random guess. Laptop (and SSD) got fried by a power surge over night. It’s not even able to return the partition table type to the OS for it to be recognize correctly.

Or, laptop got friend, SSD survived…but ESD killed the SSD when it was being transferred to the enclosure.

Looks like it recognises there is a disk, but it might be encrypted or have a Linux specific format. I’d try reading it from a Linux based system or live media.

Thank you everyone for your support! I can access my files now. There was a problem with my external SSD connector.


Marking resolved. Appreciate the update.