[RESOLVED] Framework 13 12th gen - Died after shutdown, then came back but fingerprint reader remains dead

OS: Pop-OS 22.04 LTS
Kernel: 6.2.6-76060206-generic
Expansion cards: 2x USB-C, 1x Gen 1 HDMI, 1x USB-A

Note, HDMI card is not in use. Instead the eternal monitor is connected to the HDMI port on the dock which is connected to the framework via USB-C.

Worrying issue occurred. I was using my Framework laptop, hooked up to an Anker USB-C hub and using an external monitor with the lid closed through the hub. Got to the point where I needed to go out so shutdown my framework, and turned power off to the hub and screen (since the hub is powered, I power it with the framework charge and in turn it charges the laptop capped at 85%).

Come back after 2 hours and open the lid to turn on the device but note the power light is lit, but it doesn’t turn on. Wonder if it got stuck on shutdown so hold the power button until it goes off. Noted that the laptop is actually quite hot. Try to turn it back on but nothing happens. Try connecting the charger, no lights on either usb-c module. Hold the power button again for 10 seconds despite no lights and then press it again to try and turn it on. Nothing.

Then I put it aside, so it cools down. Come back to it after a couple of minutes, check it is cool, and try to power on, and it starts. Phew. However, I now note that the finger print option on the log in screen is no more. And I can no longer enrol fingerprints for my account.

I run the following command:
fprintd-enroll -f 'finger'
and get the following output
Impossible to enroll: GDBus.Error:net.reactivated.Fprint.Error.NoSuchDevice: No devices available

I am concerned that there may have been lasting damage done to the board. I will be going through a reseating the power button part but doubt this will help, it seems it’s died.

Any thoughts?

Can you try to remove input cover, unplug battery, replace cover (be careful to not crush battery connector) and press power button a bunch of times. Then reconnect battery and reinstall input cover then try again.

Sometimes completely discharging can help reset a fault.

First I’d follow Scott’s suggestions. If that doesn’t help, I’d then check lsusb and see if anything from Goodix shows up.

Thanks both. I have reseated the power button module again as requested by support, but also tried disconnecting the battery and draining residual power but no dice.

The output of lsusb does not include a Goodix device

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 32ac:0002 Framework HDMI Expansion Card
Bus 003 Device 003: ID 8087:0032 Intel Corp. AX210 Bluetooth
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I have also tried my Fedora image and again not able to see or use the fingerprint reader.


Since this is a 12th gen unit and it sounds like it was working previous to the power loss/issue, let’s get this into a ticket and make sure to link to this forum post for context for what has been done thus far and how it came to be.

Ticket has been raised and a replacement input cover was sent out. The new cover works but needed the firmware update for the goodix device to get it fully working. Happy to say now that this is resolved for the time being.

Happy to take this as a win. Marking resolved. Thanks :slight_smile: