[resolved] Framework doesn't turn on

My fw13, 12th gen i7, stopped turning on.

Briefly blinks green on the right and left indicators and immediately powers off.

Neither internal nor external power button works.

Power button on input cover doesn’t light up.

Intrusion switch works and it did blink three times on it being triggered.

Did full reset, removing power, coin cell and battery – same symptoms.

Tried using only battery and only type-C 65W – to no avail. Tried permutations of two different cables, power adapters and ports.

Battery charge indication correctly responds to presence of battery, and (probably) charges it.

I don’t think there are any magnets on the lid switch (dumb design, why is there only one?).

Tried disconnecting all of the peripherals, and using either ram stick alone – not the problem.

No apparent signs of liquid damage.

It kind of looks like it shuts down really early, and I suspect that it might be some kind of overcurrent protection on one of rails – but I have no idea what to probe for that. Would be glad to have some help of people actually owning a schematic.

Well… the hub exploded.

Two issues on one board in 1.5 years :confused:
Since the processor is somewhat difficult to source, I guess that’s it for that board.

What hub?

This looks more like you cracked the smaller die on the soc, that would require mechanical violence. Did you reinstall the cooler and tighten the screws unevenly?

That’s about as “it” as it gets imo XD.

Did you spill liquid on it? When you say there are no “apparent” signs, that makes me think you had reason to look. Just curious.

Either way, I’m sorry for your troubles. That’s a pretty big bummer. The only silver lining is that as long as the SSD wasn’t damaged, it can be swapped into a new mainboard and you won’t lose any data. Though that may not be much consolation when faced with the prospect of buying a new mainboard.

Nothing was spilled on it. I did mention liquid damage due to macs sometimes dying due to a single (un)lucky drop of water – and that can happen unnoticed.

3rd party service inspected it, and found no problems apart from that exploded crystal – and said that it apparently ‘happens’ to these chips.

They weren’t able to find a replacement one to do a board repair.

No corner chips were found either to indicate incorrect radiator installation (which failed and was replaced half a year ago).

Peripherals did survive, but I am not sure I want to continue with framework. My plan was to use this computer for at least 4-5 years, as I did with all my previous laptops, and this together with unnecessary difficulty and cost of ordering replacement parts (new MB at a price of a new thinkpad) doesn’t put much faith in me.

Platform controller hub. The cooler was removed and installed following framework guidelines.

Macs do make some unfortunate design decisions in that reguard to the point you could start to think it’s on purpose XD.

The heatsink install is still the most likely culprint, I could see it breaking like that if the screws closer to the ssd were torqued down way more than the other ones before those got torqued down all the way too. Chips still kind of working with cracked dies is not unheard of.

The other option of actually “exploding”, the picture looks like it’s just cracked and pushed in but if it is actually exploding and missing bits that’s a different story. In that case it could be that it either had spotty paste coverage and overheated (like the destructive thermal runnaway kind not the “sensor says we should slow down” kind) in a spot with no sensors or it got fed wayy to high voltage through some io pin (but it would have to be a high current source not just a water droplet kinda connecting stuff that should not be).

Evidently there is either something wrong with the guide or your application of it then. Torquing down a laptop cooler in the wrong order can produce results like this.

If that did indeed “just happen” that would be a problem for all manufacturers using those chips so would not really make much of a difference either way.

Either way sorry that happened to you.

1 Like

I understand your frustration, and if you decided to opt for purchasing a different brand machine instead of repairing your Framework, that’s obviously your decision and you have to do what’s right for you.

I do think it’s a bit unfair to say that Framework makes the cost and difficulty of ordering replacement parts unnecessarily high. Most other makers have less repairability, not greater, and a repair often requires sending in an entire machine and being shipped a refurb or something, rather than just being able to order parts. It’s true that the 12th gen and up mainboards are pricier than some entire laptops, but I think that comes more from the size of Framework and the quantities they deal with, rather than intentionally making stuff more expensive than it has to be. It’s just the nature of the beast with a small-ish company like Framework, compared to a company like Lenovo.

But, I also understand that you’ve had a bad experience, and sometimes it can feel easier to just jump ship rather than keep bailing. I hope it all works out, whichever way you decide to go.

Most other makers really are reluctant to provide help and parts for repair, however popularity does its job, filling the market with cheap replacements.

Framework strives to do good for their repairability, yet their regulation over shipping (these discussions are banned here, so no elaboration) and difficult to get service manuals (people usually buy them from vinafix, devicedb and others, I found none leaked so far :/) are making it actively harder to board repair fw than an average laptop.

Yeah it’s kinda ironic that the framework is the one laptop I have that I don’t have the schematic for despite it being the only one that is designed to be repaired XD.

To be fair, it’s not Framework’s regulation over shipping. Not exactly. I think they don’t allow discussion of freight forwarding because they don’t want to appear to implicitly approve of it. If they are not allowed to sell and ship to a certain country due to import/export regulations/sanctions or because of specific taxation or licensing issues that are not yet worked out, then they can’t sell/ship there. And they likely don’t want to appear to be implicitly allowing people to use methods to get around those rules. My guess is that it would at the very least lead to it being more difficult to be approved to sell/ship to those countries legitimately in the future, if not result in fines, etc.

They have said in the past that they would love to be able to sell and ship worldwide, and that is the ultimate goal. But the politics and rules and taxes and such are all complicated and difficult, and they are working to add new locales all the time.

I believe that also is much to do with companies like Intel and AMD not allowing them to make stuff available. I know in the past, they made the schematics available on request, but you had to agree not to make them public, because of the rule from Intel. Something along those lines. It might be worth contacting them directly and requesting the schematics if you need them.

  1. TL;DR by current rules FF voids your warranty, and they will not ship to FFs.
  2. They’ve declined to provide them on my request, telling that they only send them to repair shops. They did not ask me whether I want to sign an NDA.

Technically, they simply cannot provide warranty in a non-supported country. It’s not so much that they “void” the warranty, but I take your point.

That’s a shame.

Again, I hope whatever you end up doing works out for you. Cheers!

1 Like