[RESOLVED] Got stuck on installing Ubuntu on DIY 13'' AMD Ryzen

so I got stuck on installing my new Framework
The current setup is as follows:
Framework 13" AMD Ryzen 7040U series, Batch 4
1 x Crucial RAM 32GB DDR5 5600MHz
1 x Crucial P5 Plus 2TB Gen4 NVMe M.2 SSD 6600MB/s

I wanted to install Ubuntu 22.04.3 LTS

The install routine runs pretty much through until the restart. I repeated the install process now several times and sometimes with different outcomes, probably because I trialed different option on the Ubuntu install
Right now and on the last attempt Like endless prompts ar coming up, see attached picture.
So if anybody could point me to the solution, it’d be heavily appreciated.


Hi @sj42, welcome to the community!

Looks like it’s failing to communicate with the graphics card properly. I have two AMD configurations available. One has the older 3.02 BIOS and the other has the current 3.03 BIOS.

For the sake of duplication, I am using the laptop with 3.02 BIOS as it matches what folks would receive from us in current batches.

First order of business would be to get the BIOS updated to 3.03. The 3.02 BIOS is a bit messy, and the 3.03 BIOS is a much, much smoother experience.

In the interest of getting this done, I’d try one of the following:

  • Try Ubuntu again, if it continues, let’s make sure this isn’t a hardware fault causing the failure to communicate with the graphics card properly (the error you show above).

  • If this still fails, I’d install Fedora 39 and then update to the latest BIOS. You can use LVFS to do this on Fedora using this guide.

  • Once the BIOS is updated, and you’ve rebooted successfully to Fedora, make sure that the BIOS is in fact, reflecting the update.

  • On Fedora:

sudo dnf install lshw dmidecode -y && sudo dmidecode | grep -A3 'Vendor:\|Product:' && sudo lshw -C cpu | grep -A3 'product:\|vendor:'`Preformatted text`
  • Make sure the BIOS reads 3.03 (or 03.03)

  • Now try Ubuntu again, this time should be much smoother. Make sure to follow step 9 closely.

1 Like

Thanks. Worked. Now I have to figure out if I’m gonna stay on Fedora or moving back to Ubuntu LTS again.


Glad this worked, marking resolved. There is a lot to love about Fedora. Might be worth sticking with it, depends on what your needs are.