[Resolved] Memory Test On Every Boot?


I purchased the base level Core i5 non-DIY model but purchased 32 GB of RAM (2 x 16 GB SO-DIMMs) to install right away, so I’m putting this post in the DIY edition section. The laptop is doing a memory test every time I power it on or reboot it. The test doesn’t take that long and has never reported any issues, but it just adds time to the boot process which is less than ideal.

This is the RAM I purchased on Newegg. I’m running Pop OS! on the laptop and had to disable Secure Boot in order to get it installed.

Any tips to make it boot without doing a memory test every time?


Mines does this too, but my clock runs fine
I just enabled fast boot to get rid of it.

1 Like

@Jeff_Ricica Do you mean the screen shows memory test and a progress bar every time you boot it? Or just the side LEDs turn green for more than a few seconds every boot?

1 Like

Yeah, it looks like just re-enabling fast boot stopped the scan from happening every time I boot the laptop. Sorry for the false alarm. I forget why exactly, but I have historically disabled this on the computers I’ve owned.

1 Like

I would definitely be willing to do that but I’m not sure exactly how. Is that something I have the ability to edit or does the Framework Team have to do it?

For some reason, I was able to edit the title of your post.

@moderaters Not sure what’s going on…might want to fix that :stuck_out_tongue: Nevermind, apparently it’s a feature for people with “Regulars” status

I thought it might have something to do with the fairly limited number of posts/comments on the forum. Hindsight being 20/20 I wish I would have jumped in months ago right after my pre-order since I’ve been fairly active in the few days since my laptop got delivered.

@Jeff_Ricica second-best time is now! :slight_smile:

After some testing, I am sure that the memory test runs always when
Quick Boot is disabled in BIOS.

I believe Quick Boot switches (some? all?) boot tests off, but am unsure
what these are and how important it is that they run on every boot.

Support does not have any further information about this.

I keep Quick Boot enabled now and hope to remember to disable it when/if something suspicious of a hardware defect appears.