[RESPOND] Several issues with tuxedOS and AMD 7840U

Hello,

I have installed tuxedo over all my computers including my framework pc and I having 4 majors issues:

  1. each time my pc goes in to hibernation and the screens begings to flicker REALLY fast to a white screen, each time something happends in the display, like moving the mouse, the screen flickers and i need to restart the pc.

  2. every time I turn on my pc (or re start it), everything runs smoothly and the pc is turn on up to the desktop, but then when i click in the applicaiton menu an app or try to open a window using krunner or double click an icon in the desktop, the pc freezes for like 3 or 5 minuts… then my kwallet appears and the window of the app i opened appear

  3. the buttons in the application launcher for sleep/restart/shut down, disapeared, and they reapear from time to time then re disapear. (most of the time they are not shown)

  4. this is a super streachy to ask help with this, but it is related to tuxedOS and I have nowhere else to ask (as people in the respective forum didnt succesfully solve the problem completly). I use for work the software Salome which is an opensource free software for pre and post processing of simulations. In any case, one can download different versions, one an ‚Äėuniversal linux‚Äô and another one for ‚Äėubuntu‚Äô among others for other linux system or even windows. but I am having several issues in tuxedOS either with the universal linux or the ubuntu version. here are the two posts I made in their forum and also a video of the different issues. this has something to do with the AMD GPU + tuxedOS as in my other pc with an nvidia gpu and tuxedOS i dont have this problems but in this pc with other operating systems (not tuxedos i didnt had them‚Ķ) post 1 post 2 and here is a link of a video of the different issues of display video

As I mentioned I am using tuxedOS in my two PCs and this issues are only present in the framework pc. maybe is due to the update Mesa? Overview: Kubuntu, its parent and some of its siblings - Kubuntu Forums
I would love to solve this issues instead of distro hop…
Thanks in advance

Does the same issue happen on a ubuntu or fedora live-image?

First time I hear somebody use tuxedOS on a Framework.

I use Ubuntu and I don’t use hibernation. Still this issue might be related to Blinking/Flashing white screen after suspend (#3187) · Issues · drm / amd · GitLab. Did you add the option amdgpu.sg_display=0 to your kernel cmdline? My system is very unstable without it. If TuxedOS uses grub you should add it by editing /etc/default/grub.

Which kernel and mesa version do tuxedos ships?

1 Like

oh boy, too many things I dont know :sweat_smile:. I will test with this option, should I set this where exactly? (sorry If i am not clear i am quite new to linux in general…) for grup not sure either…
for the kernel and mesa versions: kernel (6.5.x from TUXEDO) , mesa (24.0.1) from the link I posted in the original message Overview: Kubuntu, its parent and some of its siblings - Kubuntu Forums
but as you can imagine i am a little bit lost…

GRUB is the default bootloader of ubuntu, debian and many other systems. Most ubuntu-based systems uses it (but not all, for example PopOS uses systemd-boot IIRC). The bootloader its the software that load the kernel at boot time.

On a new/default Ubuntu installation the steps to add a kernel cmdline options are the following (cfr: Kernel/KernelBootParameters - Ubuntu Wiki):

  • run sudo nano /etc/default/grub to open the file for edit as root
  • look for the variable GRUB_CMDLINE_LINUX_DEFAULT
  • add your new option to the existing one (example "quiet splash" ==> "quiet splash amdgpu.sg_display=0")
  • run sudo update-grub to recreate the grub configuration file(usually located in /boot/[efi/]grub/grub.cfg) with your newly set variable

In case these steps don’t apply to your system you may have to figure out/ask online how the tuxedos bootloader is set up. You might want to take a look at Kernel parameters - ArchWiki.

2 Likes

I can confirm that this solved my first issue, but well the other 3 remainds. thanks a lot!

So we do not test against tuxedo or tuxedOS whatsoever. Our official recommendations are recommended as always.

That said, I will offer the following thing to try.

If this is an AMD Framework 13, you might try this, see if it helps.

Sounds like a KDE or another application issue, we do not see this with KDE on Fedora.

Hello, Yes I saw the ‚Äėofficial recommendations‚Äô but well, I want a debian based system with an update system that uses KDE and is not under the wing of ubuntu‚Ķ(specially that kubuntu uses an old kde desktop and there is no kde debian spin recommended in the official recommendations. so yeah, no of the ‚Äėrecommendations‚Äô fullfils what I am looking for. also it is not like I am trying to install a super obscure system.

If this is an AMD Framework 13, you might try this , see if it helps.

as I mentionned in my reponse, this was solved simply by adding amdgpu.sg_display=0. thanks again to @Ulmondil for his helpfull comment.

I know this as I looked in the forum before posting, but I am not looking to use fedora. the most possible scenario is that there is a missing parameter somewhere that I need to add/modify and I made a post seeking help of veterans linux users that might knew what could be the problem.