[RESPONDED] TuxedOS in framework laptop? kde desktop based distro?

I will receive my framework laptop in Q4 as I ordered it with the ryzen 7040 series and I wanted to use a ubuntu/kde based system. up to my knowledge, there are 3, ‘big’ ones.
kubuntu is based in a newer ubuntu vr, but older kde desktop
kde neon, is based in an older ubuntu vr, but newer kde desktop
tuxedos is based in a newer ubuntu and kde desktop
therefore I was going to go with the latter, but wanted to get some input from other users. or other recommendations? (ubuntu/kde based)
thanks in advance ! :slight_smile:
can not wait to get the laptop!

Hi @franco_otaola ,

Best to run the distro live first, to test the waters, you’d find first hand if it has issues or none.
which ubuntu version is it based on by the way?

1 Like

Thank you for your kind answer,
Up to what I know (it is not easy to find the information, it is based on ubuntu 22.04 LTS with some modifications and updates) but couldn’t find it clear.

Alright cool, right off the the bat, I would check if sound works, video acceleration, wireless,

see to it that you wifi doesn’t just drop you randomly, no hanging with normal day to day desktop use.

1 Like

Not Ubuntu based, but I have been very happy with EndeavourOS, which is Arch based. Plasma aka KDE) is a desktop environment option in the graphical installer. Endeavour + Plasma + X11 had been my fault driver for almost 3 years now.

thanks @Loell_Framework I will keep in mind this when I receive my machine, hope it goes well!
@D.H thanks for your insight, for the moment I will stay on the realm of ubuntu based distros, for a beginner is the best approach. maybe in the future I will go with other distros for more experienced users. but at least ti is good to know! :slight_smile:

Please excuse the necro, but I got a question:

Have you been running Tuxedo OS on the Framework Laptop in the end?
And if yes, does it work well?

Hello @Numerfolt ,
sorry for the late reponse.
Yes, I am running tuxedo OS without mayor issues. here is what I am having as problems right now:

  1. when I turn on the pc, everything turns correctly the desktop and everything, but when I open my first window or interact in any way (like open the lancher and writing a letter for making a search) the pc freezes for like 20/30 seconds. once this has happened, the pc works like a charm.
  2. the sleep/restart/shut down bottums in the app launcher have disapeared. a few times have re apeared but since a little bit of time they have never shown up again… I have not digged too much into this, as the arrow is still shown and i click on it select long out and then turn off/restard the pc from there.
  3. I can see some errors when the pc is turn off (and also have several different boot screesn) here you can see my post about it. [RESPONDED] Removing several "different" framework screens while booting - #4 by franco_otaola
    it is supposed to be solved with the kernel 6.7 (maybe) but for the moment tuxedos is at 6.5 maybe when ubuntu 24 LTS goes out, the new tuxedo goes out with the new kernel, but I dont know at all about this.
  4. sometimes the icons in the desktop disapear. they are not deleted but you can not see it, but if you go in dolphin $HOME/Desktop you see everything.
  5. when I connected my framework pc to an old low res screen i could not succesfully make it work in a right configuration so it would be ‘useful’ in kde. like it was always not the corerct size either the framework screen or the other screen. I spend like 20 minuts then I gave up

6bis. the finger print reader, I dont use it. it is not a functionality i am used to so I dont even know if it should be setted up or anything. so yeah, that I can not tell you…

IMO is usable and I like it. I will only change to the newer tuxedos goes out specially for the next release of kde and the newer kernel.
hope it helps (and if you use and get any of the issues and solve it would be nice to share the solutions)
best regards

I would STRONGLY recommend just going with Kubuntu. I had a lot of problems with wifi on TuxedoOS.

I had literally ZERO issues with the 13’ inch AMD framework

Just throwing this out there, but Fedora KDE has worked flawlessly on my 11th Gen intel i7 board and my Ryzen 7 7840U AMD board since day one.

Did you change anything regarding wifi? I kept losing internet, I tried a couple things I found on this form. But nothing seemed to solve the issue. I figured it had something to do with TuxedOS being made for other PCs.

Nop, I didnt made anything at all. I had to install tuxedos 2 times due to another issue that I dumbed, and the first time it worked a little bit bugged but might have been that I dummed something. but in either times i have not experienced any issue in the wifi :slight_smile: . maybe try to re installing it?

two frameworks? lol bravo! I envie you… I still keep in debian based, even if it is quite popular right now I am not planning to go fedora route. at least for now. but it is good to know as clearly I not going out of KDE

No, one laptop that I’ve upgraded over time. My original 11th Gen board is in a tablet enclosure I’m going to gift to a family member.

Nah I’m happy with Kubuntu, I even got the Steam version J.A.C.K working.

Maybe we could find some clues in networkmanager, can we have the whole output from this command?

journalctl -u NetworkManager -b 0

do this when the wifi is acting up. :slight_smile:

Wow, I didn’t want to start an avalanche…
Thanks for the answer though, I’ll give TUXEDO OS a try!