[RESPONDED] AMD 13 7840 Not charging with upper right usb-c module

OS: Fedora Linux 39 (Workstation Edition) x86_64
Host: Laptop 13 (AMD Ryzen 7040Series) A7
Kernel: 6.6.8-200.fc39.x86_64
AMD 13 7840 DIY
BIOS 3.03

Could charge it with upper right usb c port.
When i plug it starts and then stops i a second. then start again then finally stops…
This happens only with upper right usb c module. With left usb c everything works with same charger (100W Baseus). Tried different chargers, different cables. Tried swapping upper left right usb C modules. Same behavior.

First idea was its some kind related to charging limits. was set 80% switched back to 100.
Later found that if its high charged then charging to full starts with no problem.
Looks like its fails to start charging with upper right port when below 50%

1 Like

I added the image from this knowledge base article to make this easier for us to discuss.

To make sure I am clear, you are using the provided USB-C expansion card, not directly connecting and bypassing the USB-C expansion card? Sounds like you are using the card, but just being super sure I have this detail correct.

So here’s what is the best approach to determine if there is an issue or not.

  • With it switched and set to 100% capacity, allow to drain to say, 85%, plug in power with the laptop powered on and booted into Fedora. Is the charging working? And, is it charging to say, 99%? If successful, next test.

  • With it powered on, allow to drain to 40 to 45%. Attach power, allow to charge which should hit 99%.

Track this with expansion bay 3 (upper right usb c port), make notes of the results and let me know if you are still having issues getting charged.

yes, i am using 3rd slot with usb c expansion card. sorry for confusing…

100% Capacity
So here are the results:
Discharged to 85%. pluged in charger in 3rd slot. started chargind. up to 98%.
Discharged to 39%. After cable plugs in. its starts charging then stops in 2 seconds.
The led indicator near the usb c expansion slot is: solid orange for 2 seconds, then turns of, then flashing 2 times short orange, then turns off.

UPD. at 31% with several plug in plug out it started charging

Hmmm, let’s get this into a ticket. Please make sure to link to this thread in the ticket for context.