[RESPONDED] Archlinux framework 13 HDMI not detected by arandr


I am running archlinux with i3 window manager and xorg in a new framework13 laptop. Updated to the latest Bios.

Linux archframework13 6.6.1-arch1-1 #1 SMP PREEMPT_DYNAMIC Wed, 08 Nov 2023 16:05:38 +0000 x86_64 GNU/Linux`
Framework Laptop 13 (AMD Ryzen 7040Series)

I have a problem that xrandr does not detect the HDMI monitor when plugging in an hdmi cable. I have ruled out a problem with the expansion slot itself as I plugged it to a lenovo laptop as usb-c and detected the monitor fine.

I am at the end of my rope and not sure what more to check. Would appreciate any help!

I had a similar problem where hdmi in the “2” Slot was not recognised by windows. It turned out the whole usbc was not working (not even charging).
(Slot 2 cannot do display out so this may have been the trigger)

I got it running again by going into the BIOS and using the “Battery disconnect option” Opening it up and manually powercycling the board may have also worked.
I guess some firmware was stuck in a bad state.


@Lefteris_Karapetsas This will be the best place to start off at.

1 Like

Hey both of you thanks a lot!

I had not realized that there were restrictions on the slots though I looked at exactly the diagram shown during the setup. I just missed it.

And yes the HDMI expansion card was on the number 2 slot. I am travelling now and don’t have access to an external monitor but once I can confirm I will edit the post and mark as solved.

This might very well be it!

Awesome, happy to hear we have a path forward. :slight_smile:

That was it for anyone else looking at the post. It was the slot’s fault

1 Like