[RESPONDED] Distorted Audio on FW Laptop 13 with Ubuntu 22 LTS with Rodecaster Pro

Hi all,
I am haveing major problems with my Rodecaster Pro, if I am using it with my Framework 13 AMD Linux (Ubuntu 22.04) Laptop. The sound seems to be completly distorted.

I haven’t found a solution via google jet, but I would be happy, if you have any helpful information on this topic.


Welcome to the community!

As a former podcaster, I did some digging and found an older bug report that appears to have never been resolved. More so, at that time, appears to have affected any distro under the sun when using the Rodecaster Pro.

Happened upon this, got me thinking - while far from ideal, I wonder how this would fare if it was connected through a reliable (brand name) USB Hub pushing ONLY the Rodecaster Pro’s USB-C connection.

My older gear (in storage) is all M-Audio and worked reliably, so I cannot speak much on Rodecaster hardware. But seems to me that this might be a path forward for testing (USB-Hub). I’m spit-balling here, so keep that in mind.

Hi Matt, thank you for reaching out.
I tried the following chains

  • Framework - USB-C - HP Hub - USB-Switcher - USB-Hub - USB-A/USB-C Cable - Rodecaster (my usual connection, works well under windows)
  • Framework - USB-C/USB-C Rodecaster
  • Framework - USB-A/USB-C Rodecaster

For all connections I had the same issue.

From everyone, who else might be interested in this topic:
I got official confirmation from the Rode support, that the Rodecaster Pro does not support Linux. :cry: