[RESPONDED] Expansion cards (USB-A) require unplug-replug before working on boot


On bootup, the expansion cards on the laptop aren’t being recognized, and so I can’t use the USB ports until I unplug and plug back in the expansion cards. This isn’t as big of a deal as it could be, but it’s quite annoying.

This isn’t an OS-level issue, because the BIOS didn’t recognize the USB keys I tried to boot off to first install an OS until I figured this out, originally I thought my laptop was busted.

Is there anything I can do about this? Or does my mainboard just have some issues?

Thanks in advance.

One data point that indicates it may be something specific to your particular laptop: I booted successfully from a USB stick (repeatedly) with just the USB-A expansion card inserted prior to power-on/reboot. No reinsertion required. Similarly for the HDMI expansion card: it’s been ready for use every time I tried, without reinsertion.

Hi and welcome to the forum.

  • What OS are you using and have you tried a alternative?
  • Which expansions cards ? All?
  • Which do you have and have tried.

Hi @mahervelous. I would recommend submitting a ticket to our support team here: Framework | Support so they can ensure your laptop is performing as intended!

Thank you and stay safe!


Hi @amoun

I have windows and arch linux (and the bios as mentioned).

On windows, the usb-a slots require unplug/reinsertion, while the HDMI does not. I can also plug a usb-c->usb-a adaptor into a usb-c slot and this works after bootup, so the usb-c slots appear to be working as intended.

On arch, the usb-a slots require unplug/reinsertion, and the HDMI does as well (even restarting X before unplug/replug doesn’t detect the monitor).

On the bios, it requires plug/unplug for usb-a, I haven’t tried any of the others and don’t know the intended behavior so I’m not sure what it’d look like anyways.

These are the only cards I have.

I’ll open a support ticket, thank you @_JB_bak

1 Like

Did anything come of the support ticket? I’m experiencing similar issues and so are others per this reddit thread:

Using a 12th gen (1260P) here (with the recent bios upgrade).
A USB-A port (front right side) died on me today twice. Worked after re-plugging the expansion card.
I also had a Lenovo USB-C Hub connected on the other right port where the USB-A ports did not work either. Additionally I had a 4k monitor on the left side with mouse & keyboard passed through which continued working fine throughout.
(Also a thunderbolt nvme enclosure on the final port which also continued working fine… I’m pretty full of peripherals currently ^^…)
Hope it’s not some sign of failure. :-S

It’s worth checking the logs for potential power drops. This is with a Linux distro I assume? If it is, do you happen to have TLP installed?