[RESPONDED] Extremely high power consumption with lid closed

Yup, this is still a problem, 6 months after the AMD FW 13 came out. It has gotten pretty frustrating and it is bad enough that I am contemplating making it a warranty claim.


  • Very high power drain with the lid closed. Overnight I can easily lose 60% of the battery. This is results in a much higher battery cycle load than a normal laptop would (like a Thinkpad). It doesn’t always do it, it seems quite random.

  • Sometimes with the lid closed (and no active processes, just everything at idle) the CPU comes up to full power. I mean 100% screaming and the case gets so hot I can barely touch it. This has happened several times now, usually in my backpack. It gets so hot that it seems genuinely dangerous for the battery. As I said, so hot I can barely touch it. If I open the lid and let it sit for a minute, it quiets back down.

So, it’s not going to sleep with the lid closed, and sometimes it then sits in some kind of spin loop somewhere with the CPUs maxed out.

I’m on the latest Linux Mint - hardly an exotic OS choice. I’ve tried several different kernels. No dice.

Where is the fix for this issue? This (plus the overly bright minimum screen brightness, which has also been covered in the forums in multiple places with no resolution) severely undercuts this otherwise excellent machine (that reviewed extremely well, apparently no reviewer bothered to mention the suspend issues). If I had known about this up front - and that months on there would still be no fix, I would have just gone with another Thinkpad.

I’ve gone through the multiple scattershot forum threads for this issue and they all just trickle down to no activity with no actual fixes. It seems like everyone just gives up and FW isn’t really forthcoming with a fix.

The overheating issue is pretty severe - if it happens again, I am going to consider making it a warranty claim. The battery controller hardware itself should not be letting the system get that hot, especially with the lid closed.

FW13 AMD 7840 LM 21.3

I’m happy to run whatever debugging scripts that will help, but I am going to expect an actual fix for this at some point.


This is likely an OS configuration issue. On Windows, I lose about 1% for 1 hour of sleep and with the other official support Linux distros (Ubuntu, Fedora), I have seen a lot less power drain.

1 Like

Assuming overnight meaning <10h, your laptop somehow uses more power sleeping than mine idling with the screen at 20%, wifi connected and bluetooth on so something is probably quite screwy there.

I would still call sleep power consumption excessive but it should be in the order of 1-2% per h not 6+

Have you tried running this script?

Certainly not exotic…yet at the same time unsupported.

I would start with trying an officially supported distro.

Regardless this sounds like your systemd settings regarding suspend, sleep, hibernation are not set correctly. You might have a conflict between CInnamon and systemd settings. You also might have a service in the background running that is preventing sleep.

Which kernels. Your lack of specificity is not helping.

1 Like

This is important. It can feel like distros are all the same with just different paint schemes, but this is not the case. Kernel version and available libraries all very much matter. Hence the reason Framework has gone out of their way to define “certified” Linux distros to use.

Mint does work, as one of the community moderators here runs it on their Framework 13 (Intel however). There are just no guarantees.

I hope that the responses in this thread appear as reasons to hope for improvements with your situation. You really should be seeing better standby performance.

1 Like

Hi @Jeremy_Billheimer ,

Do update us tha status of you FW 13 lid not suspending, just re-echoing what was said, do try Fedora 39 live or Ubuntu 22.04 live, if behavior still persist, kindly open a support ticket if you still haven’t.

cheers! :slight_smile:

Y’all, this is solved. It was the kernel.

To everyone coming on Linux Mint with the same problem: It’s the kernel.

For reference, I’m on LM 21.3.

I updated to a mainline kernel 6.8.6, and WOW, this is what this machine was supposed to feel like. Power issues completely gone. Suspend mode works, I lose maybe 1-2% overnight. The case is noticeably cooler all the time, especially with the lid closed. Performance seems better across the board, especially with thermals.

It is pretty clear you absolutely need a 6.8.x kernel for the AMD 7040. It isn’t an issue with Linux Mint or it being an “unsupported OS” (LM is 99% Ubuntu, that’s one of the main points of Mint!). It isn’t systemd. It isn’t that you didn’t run a Python script (that doesn’t turn in to any actual fix). It’s your kernel version, and unfortunately LM tends to lag on kernel versions along with the kernel patches needed for the AMD not making it into the older kernel series.

You can google how to install a mainline kernel, it isn’t hard, nor is it hard to undo. You will see some people say not to touch mainline kernels, and for most users this is fine because they aren’t running an AMD 7040. If you are running an AMD Framework then you need a 6.8 kernel, period, full stop. Go get you one. This machine is awesome on 6.8.

Dear Framework:
This is all you need to say, instead of letting post after post after post just hang with no closure. Probably a ton of issues people are having is that they just don’t know they need to update their kernel to a 6.8 series. It’s really easy.

To everyone else on AMD and Linux and still having power trouble: Try a 6.8 kernel and see if that fixes your problems.

1 Like