[RESPONDED] Fedora KDE 39 - Graphical glitches after waking up with monitor connected

So, usually my setup will entail plugging my laptop into my external monitor for a while, and I’ll have it go to sleep while it’s connected. After waking the laptop up while it’s still connected to the monitor and interacting with the desktop like right clicking or swapping activities, it’ll result in the desktop space shrinking and causing graphical glitches in the remaining parts.

Here’s a screenshot of what it looks like

Some things of note are that:

  • My monitor right now is an LG 27GN950-B, running at it’s overclocked 160 hertz at 4K
  • I’ve connected the laptop to the monitor through a 2nd generation DisplayPort expansion card
  • The shrunken desktop space is the same size of my laptop screen
  • The wallpaper will scale down to the shrunken space
  • Only the desktop is affected, nothing else. Windows, menus, and panels render fine, although they leave those ghosting artifacts in the empty space of the desktop

This doesn’t hugely affect my experience since I can always quickly unplug and plug back in the DisplayPort cable, which fixes the issue completely until the next time it goes to sleep. However, it’s a glitch that’s definitely noticeable, and it would be nice to not have to.

Had a similar issue myself with Fedora Kinoite 39 (KDE). Updating to the 40 pre-release, that now has KDE 6, solved the issue. That being said 40 isn’t even officially beta yet so don’t update to it unless you are running a Silverblue/Kinoite variant (be sure to pin your last 39 deployment so you can roll back if needed). KDE 6 has it’s own set of bugs but overall has been better then KDE 5.

Didn’t encounter these issues with Gnome (Silverblue 39) but its monitor scaling sucks and has very bad text blurriness with fractional scaling (125%, 150%, etc…). KDE 5 still has a bit of blurriness with KDE 6 having the least noticeable text blur between the 3. Still not as good as windows but it’s as good as it gets on Linux.

Good to hear this eventually gets fixed, and thanks for notifying me!

Could it be something to do with Kwin compositor? Haven’t visited the KDE side of things recently but isn’t there an option to disable that and see if screen glitches subsides?