[RESPONDED] Framework 13 AMD Display Flicker on Fresh Ubuntu 22.04 LTS Install (latest OEM kernel + BIOS)

Hi,

I’m having display flicker issues after replacing my dead 11th gen (1165-g7) Intel mainboard with a new Ryzen 7 AMD board. I did a fresh install of Ubuntu 22.04 LTS, following the guide.

The flicker does not occur in BIOS nor did it occur during the installation. It seems to flicker more often after the screen is dimmed by the OS due to inactivity, or after resuming from sleep. These together make me think this is probably a software issue.

Anyone have any ideas to troubleshoot, maybe some logs I can look at for errors? I’m really hoping to confirm it’s just software because I don’t want to have to send a board back and have no laptop for another few months.

Edit - video of the issue: framework-amd-flicker.mp4 - Google Drive

Thanks!

Perhaps this can help:

[RESOLVED] Intermittent White Screen Display Faults? - Community Support - Framework Community

Thanks for the suggestion! Unfortunately, setting the above boot parameter (amdgpu.sg_display=0) does not fix my issue

BOOT_IMAGE=/vmlinuz-6.1.0-1027-oem root=/dev/mapper/vgubuntu-root ro quiet splash amdgpu.sg_display=0 vt.handoff=7

Still flickering

This appears related (if I look closely enough during boot / periods of high CPU usage, I can see these artifacts on my hardware as well):

I actually remember seeing this “static” booting up the live image during installation, and I just brushed it off as new hardware running on an old Ubuntu kernel, figuring the OEM kernel would fix it (it didn’t). FWIW, I’ve tried resetting the display cable a few times with no changes.

I’ll try running the live image with Ubuntu for a bit, allowing the power saving features to take effect to see if I can reproduce the flicker there and compare to a live image of a distribution with a more recent kernel to see if I get the same issues.

My gut feeling is that this is software, hoping to pin it down before my board goes out of warranty.

That feels like a cable connection issue. Please get this into a ticket, link to this thread and verify this is happening on the live USB as well. If it does, it’s likely a hardware/cable issue.

Thanks – so I tried running the Ubuntu live USB, couldn’t reproduce the flicker issue. Then I realized the Ubuntu live image uses X11 while I’ve been using Wayland while I’m experiencing the issue, so I tried launching GNOME using X11 on my install and surprisingly I didn’t get any flickering.

Okay, so something to do with Wayland, I thought. Fedora’s live USB runs Wayland, so maybe I can reproduce it there, I thought (I couldn’t). Finally I booted back into the Ubuntu live USB, dropped to a TTY and manually started a Wayland session of GNOME, which seemed to work for a while but then crashed back to TTY. Checking syslog the last entry was:

i2c_designware AMDI0010:00: i2c_dw_handle_tx_abort: lost arbitration

I’ve seen that before when tailing syslog on my install, but it doesn’t always correlate with the flicker so it’s probably not related.

I’ve also noticed that if I interact with the keyboard or the trackpad the flicker will stop while receiving input, but then if I don’t touch either input device for about 10 seconds it will start flickering again. Maybe it’s related to a power saving feature?

Should I still log a ticket even though I couldn’t reproduce (at least not with an X11 session)?

Using the method for checking on Ubuntu (installed version), what BIOS are you using?

SMBIOS and CPU as reported with above:

sudo dmidecode | grep -A3 'Vendor:\|Product:' && sudo lshw -C cpu | grep -A3 'product:\|vendor:'
	Vendor: INSYDE Corp.
	Version: 03.03
	Release Date: 10/17/2023
	Address: 0xE0000
       product: AMD Ryzen 7 7840U w/ Radeon  780M Graphics
       vendor: Advanced Micro Devices [AMD]
       physical id: 4
       bus info: cpu@0
       version: 25.116.1

Looks good.

Okay, we see this isn’t an issue with X11 (UbuntuU) and when you did Wayland on USB (Fedora), you indicated you did not see an issue there as well.

Let’s start by removing the parameters from your install, then sudo update-grub (Ubuntu)

amdgpu.sg_display=0 vt.handoff=7

I don’t see amdgpu.sg_display=0 causing this issue. And Virtual Terminal Handoff also should not be causing this, although it’s not tested, either.

Let’s try:

  • sudo apt update && sudo apt upgrade, reboot.
  • Lose both parameters. update grub, reboot.

I dropped amdgpu.sg_display=0, I had to drop splash from /etc/default/grub to get rid of the special vt.handoff=7 param Ubuntu passes.

I think Ubuntu sets the vt.handoff param when using Full Disk Encryption to hide the “ugly” password prompt. :smiley:

In any case, after removing both params, still flickering in Wayland. :frowning:

Ah, good point on the LUKS element, yeah, let’s get you into a ticket. Need to get a gander at the logs to see what might be happening here.

2 Likes

Are still on Linux 6.1?

This is the specialized OEM C kernel for those who followed our Ubuntu 22.04.3 guides. We will be moving folks over to OEM D (6.5.0-10) soon enough for 13th gen.

Thanks, I just submitted a ticket. I’ll update the thread if I learn anything!

1 Like

After some troubleshooting and reviewing logs we came to the conclusion that there didn’t appear to be a software reason for the issues. The root cause of the issues appeared to be related to the display.

After replacing the display I’ve got no more flicker and the weird RGB static is also gone. Thanks to @Matt_Hartley for sticking it through with me and troubleshooting this issue to its conclusion!

2 Likes