[RESPONDED] Framework 13 AMD Random reboots only when charger plugged in

Hi!
Framework 13 DIY AMD 7040

AMD Ryzen 5 7640
WD_BLACK SN770 500GB
Crucial SO-DIMM 16GB kit 2x8gb 5200Mhz

Just got my Framework this week and put it together had an issue with my ssd (random reboot then the laptop displayed that the boot drive was missing.) Bought a new one and it was all good but now I noticed that whenever I have a charger connected the laptop will in random times just restart. Doesn’t matter if it is under load or I am just browsing the web. When I am on the battery it works normal but connect a charger and in some time (it can be within minutes and other times it will hold for a long time) it will restart and then boot back to the os like nothing happened.

Tried charging using both of the top usb-c ports so far.

Tested on Ubuntu 24.04, Pop!_OS 22.04, Windows 11.

*I did more testing and on W11 it is doing the reboot thing on battery also I didn’t observe this on linux. Also in linux this would happen more sporadically on W11 it does this all the time. Hmm…

*Also I now experienced a shutdown so not a reboot on W11 where when i connect a charger the laptops screen gone dark and the fans on full blast then it turned off. I was not doing anything cpu/gpu intensive but the laptop was fairly hot to the touch.

I tested a 65W Vention 3-port charger and a 65W HP charger also didn’t help.

Would love any tips you would have thx!

Welcome to the forums!

That sounds pretty strange. :confused: I’ve had my FW16 running on the charger for days on end.

Here is a general first-line fix for many hardware-based ills. Might not solve it, but with the BIOS-based battery-disconnect, it’s simple enough to do any time you discover an odd problem – and it often does fix the problem.

If you try it, please let us know whether it solves that one.

Hi @Maro , welcome to the community :slight_smile:

Can you try all other ports with the official charger and see if it’s the same issue happening?
also try carefully connecting the charger directly to the expansion slot without the usb-c module for all ports, see if random reboot issue persist.

So wau… what a troubleshooting journey I had.
I found out thx to windows being a ram hog that the problem is probably the ram. I tried running Prime95 and it will crash every time if the charger is plugged in (Any charger I tried also when is the charger plugged in any slot/directly without expansion cards). But it will work fine if on battery. I have never seen this. :joy: So tried memtest that said that the rams are all good. Reseated the ram = still the same. Tried only one ram slot (slot 1) and presto it works ok when plugged in. tried the second ram stick and it works fine (slot 1) but when I put any of the sticks in the slot 0 the problem comes back. I checked the formus/reddit and found out that speed any lower then 5600Mhz is a no go I never heard of this being a problem but I bought another ram sadly could not get 2x8gb at that speed so i got one Kingston FURY SO-DIMM 16GB DDR5 5600MHz. When the ram gets here I will test it in the 0 slot to confirm if the slot is the problem or the speed.

Also I bought just the laptop no charger and no ram no OS so can’t really test with the official one. But I tried it with the two that I described before and now also with a 120W HP dock and it was all the same.

Here is a vid of the test:

Also I think it is pretty bad DIY consumer experience when I am selecting that I want to use my own ram it should display in red that you need to get the required speed/brand. No where was this disclosed in the purchase process I think. This needs to be right there because most buyers will order the RAM right after buying the laptop to ensure it arrives on time. I know there is a website that shows the “supported ram” but If I don’t know I need to look for it how am I suppose to know that i need 5600Mhz most motherboards have 5800Mhz as a stated maximum what can they do not that you need exactly 5600. When I was googling around I found A lot of peeps that also bought the wrong speed. And when it is a known problem for a long time it just leaves sour taste in my mouth not to mention the money spent to get the correct ram/speed. But hey let’s hope it is the speed and it also was a great troubleshooting hunt that I didn’t had in a long time. XD

When you explicitly choose to build your own machine, the assumption is that you will make all of the decisions. I can’t fault Framework for that. (Cue the Monty Python “Whizzo Chocolate Factory” sketch: “First, there is the jelly fondue. Now this is very nasty, but we can’t prosecute you for that.” :wink: )

(For what it’s worth, I didn’t know about the requirement for 5600 RAM either.)