[RESPONDED] Framework 13 not HDCP compatible?

I’ve got a Framework 13 with Ubuntu 22.04 installed. When I try to watch TV on 7plus.com.au (streaming website of free-to-air channel 7 here in Australia) I get an error saying my laptop isn’t HDCP compatible.

I’ve tried in both Firefox and Chrome, so I don’t think this is a browser issue.

1 Like

Do you watch any other streaming services like Netflix or the like? Those require HDCP as well (well, for much of their content anyway), so I’m just curious if it’s some kind of conflict with that site, rather than simply not supporting it at all. HDCP has been around as a standard requirement for a long time. Not saying it’s impossible, but I’d be pretty surprised if the Framework 13 didn’t support it. If it didn’t, it would be impossible to watch stuff like Netflix/Hulu, etc.

My guess is some kind of software or driver issue, rather than the laptop simply not supporting HDCP at all. Hopefully, others with more knowledge about such things will chime in. Searching around the web I found a scattering of complaints about this happening on other laptops as well. So hopefully it’s just a bug or driver issue that can be corrected.


This definitely sounds like a browser configuration issue. I also use Ubuntu 22.04 and have no issues with HDCP. Are you using Snaps or .deb packages?

1 Like

Did you make sure to enable DRM in the settings?

Thanks for the replies:

  • I tested Netflix on the same laptop and browser and it works. I also tested the ‘live TV’ streaming from another Australian TV network (9now.nine.com.au) and that works too. So problem seems to only be with 7plus.com.au

  • I tested 7plus.com.au in Firefox, Chrome and Opera. Firefox and Opera were installed by Snap, but Chrome was the normal DEB package from apt. It failed with the same ‘HDCP’ error in all 3 browsers

  • DRM is enabled in Firefox settings

It might be something specific to watching live TV on 7plus.com.au, maybe whatever software they use to check for HDCP compliance is oversensitive and flagging devices that are compliant.

1 Like

Hi @Timothy_Edwards, welcome to the forums.

Just to rule out some misconfigs, have you tried with firefox on Ubuntu 22.04 live usb?

1 Like

Just to rule out some misconfigs, have you tried with firefox on Ubuntu 22.04 live usb?

I’ve now tried that, but same problem