[RESPONDED] Framework 13 Ubuntu 22.04 Login Issues

Framework Laptop running Ubuntu 22.04
Upon successful login manager returns me to login screen.

I can switch to terminal and login, but system becomes unstable and throws random error messages or throws a kernel panic

I have worked through the document titled Black Screen Or Login Issues (Ubuntu 22.04)

What next?

Does this also happen on a live system? If you haven’t could you please try booting from a USB and check if everything works or not.

Which motherboard/CPU do you have? I see that you have a 03.06 bios but that is not up to date for any model.

Is this some document from framework? On somewhere else online?

There’s a technique that works well as a first line of defense against such problems, described in this message.

One thing not mentioned there, which would only affect Intel 11th-gen Frameworks: in addition to logically or physically disconnecting the battery, you might also need to physically disconnect the Real-Time Clock battery as well.

1 Like

Based on the image, feels like a memory issue, possibly a corrupted file system - but I suspect ram.

Test with a live USB, if no issues there, likely a corrupted file system. Hopefully you used our KB articles to help you get your home directory backed up if anything was critical.

In the case of a likely corrupted file system, this may help:

  • Boot to a live USB.

  • sudo fdisk -l

  • The NVMe will be listed as something like /dev/nvme0n1 and its partitions as /dev/nvme0n1p1, /dev/nvme0n1p2, etc.

  • sudo umount /dev/nvmewhatever the designation is.

  • Automatically fix errors:
    sudo fsck -y /dev/nvmewhatever

  • or manually make selections:
    sudo fsck /dev/nvmewhatever

  • Reboot and cross your fingers. Again, this assumes it is not a memory issue. In that case, you’d want to pull a stick at a time, swapping back and forth and testing. Memtest stuff is meh at best and is often times not all that accurate.

I tried the ‘disconnect from drive’ procedure.

I am unable to boot from a USB drive, it gets to the framework ubuntu loading screen and stays there.

Based on this and the error messages I see prior to locking up when I boot from hard drive, I agree that this is most likely a memory failure. I’ll order a replacement and get back to you.



Update: Replacing the memory resolved this issue.