[RESPONDED] Intel Framework Laptop 13 Crashes when using Xe Graphics on Linux

Hi, I got my framework 13 DIY edition today, and I’ve been having trouble trying to get ubuntu 22.04 working on it, the installer would only run with safe graphics, but I could install it after that.
My problem is that after installation, starting the laptop will just freeze at the login screen and turn into a small square of pixels where the cursor was (picture attatched here)

If I start it in recovery mode then I can log on fine, but starting up normally always fails with the same result, I’ve tried reinstalling as well as the terminal command from step 9 on the installation guide, please could I get some help with this? Thanks :slight_smile:

UPDATE: Tried Reinstalling ubuntu 22.04, installing ubuntu 23.04 (same issue), installing fedora 38 (crashes when launching installation media), reseating memory and storage, disabling secure boot, reinstalling intel graphics drivers in recovery mode.

I’ve noticed that I can only get into the OS when I’m using software rendered graphics, booting normally will just crash in a few seconds. I checked my firmware version with the framework-system-details app, and it was last updated on the 4th of this month. I’m at my wit’s end here, so help would be appreciated.

Wild, you’ve done everything I would have done. This sounds like maybe a defective iGPU, have you emailed framework support?

When you get to that screen, can you move to other virtual terminals? I can’t remember which ones Ubuntu has open, but press ctrl-alt-fx where fx is a function key usually between 1 and 6 inclusive.

If it works, you will get a text login prompt

For some reason I am getting a 403 forbidden when I try to edit the above response.

Anyway, you should then be able to log in and check Xorg.0.log to see why X is crashing.


Scott =)

Have you run any memory tests?

Yes, in recovery mode and by turning off quick boot in the bios, memory’s all working fine.

Just tried ctrl-alt-f3 when it crashes after a normal boot, no success there, but I can do it in recovery mode and get the Xorg.0.log from there if that’s helpful.

Contacted framework support this morning, so hopefully I hear back from them soon.

1 Like

Welcome to the forums! It may be a few days due to us being flooded with tickets for the Framework 16 pre-order launch. But yes, you will definitely hear back so we can get this sorted.

1 Like

Alright, thanks a lot!

1 Like