[RESPONDED] Intermittent Bluetooth Mouse Clicks in Linux

I am having inconsistent clicks with my logitech m510 mouse with my new linux computer. Everything about the mouse works properly (tracking, scrolling) except the clicking action, which works intermittently.

  • If I depress the mouse button for longer, it seems to be more reliable.
  • kernel version 6.1.0-1028-oem
  • ubuntu 22.04.3 LTS
  • framework laptop 13

What I have tried:

  • I have dissasembled the mouse and cleaned it
  • I have swapped the mouse to my old windows laptop and it works fine, pointing to Ubuntu
  • I have tried disabling autosuspend in the kernel
  • I have tried inspecting the mouse with Solaar, most options are greyed out for my mouse
  • I have tried moving the mouse receiver to a different expansion slot

I appreciate any help!

Hi @Andrew_Noble, welcome to the community! (Forgive me if we interacted elsewhere, this post indicates you’re new in the header for admins).

I do not have access to this specific mouse, however, I do use a Solaar alternative called Piper for my Logitech wireless G305.

Using sudo apt update && sudo apt install piper -y should get you where you need to be. Should also include libratbag so that stuff isn’t grayed out (if the mouse is compatible, which it may be).

As to the behavior itself, this is tough. I seriously doubt the logs will tell you much.

An interesting way to “lazy grep” what is happening may be to run:

sudo systemctl status bluetooth

Then look for the error logs and share them here.

Failing that, it seems like you could get a stream of events from your mouse using this package libinput-debug-events(1) — libinput-tools — Debian testing — Debian Manpages (should be available on Ubuntu). If the click event does not register at all I would suggest that perhaps the mouse itself is at fault. Perhaps the physical switch in the mouse is damaged or in the process of failure.

But actually I think piper and ratbag will give you better troubleshooting tools anyway…

Really appreciate your help. This is the third forum I’ve tried to get help from

I am having trouble getting ratbag to cooperate with my mouse, it might just be unsupported, but this is a pretty run of the mill mouse, I had to manually add a device file in /usr/share/devices according to this tutorial.

Yet I am still not getting the mouse to show up in piper. Here’s some output from ratbagd that might be enlightening.

Heres the output from the bluetooth service

Did you guy have any more thoughts on this issue? @Matt_Hartley @SoldierSvejk

Here is a device file that might work, depending on how old your mouse is…

You add devices like this: Adding a device · libratbag/libratbag Wiki · GitHub

Here is a github issue, supposedly it should work with the m510 but there are some issues with button remapping. See the end of the thread here (worth reading all the comments): Support for logitech-M510 · Issue #714 · libratbag/libratbag · GitHub

Yeah, after looking at the OP’s images, I think that this device file may be the best option.