[RESPONDED] Kernel won't boot - 6.7.3-200 Fedora Workstation 39, Intel 12th gen

Is anyone else having trouble with the new 6.7.3 kernel? I cannot boot it. I had to boot the older 6.6.14 in Grub.

I reported here:

No problems booting, however Issues with Linux Kernel 6.7.3 and 6.7.4 - Fedora Discussion and 2263340 – Linux Kernel 6.7.3 Following A Hardwired Connection Wireless Adapter Intel Wi-Fi 6 AX210/AX211/AX411 is Missing . It has plenty of stuff wrong with it but booting has not been one of them, at least for me.

I also had problems booting the kernel and experienced the Wifi bug, after upgrading. @nadb @Adonnen do you by any chance have tlp installed ? (as recommended for better battery life)

The reason why I am asking:

On my first boot with the new kernel it took more than 5min to boot the system (the laptop was docked). Trying to execute any command with as a super user caused the system to freeze completely. Unplugging the dock did not help in that state and connecting to wifi networks was impossible. This behavior continued until I undocked and reset the laptop.

Now I was able to fix the issue for me. It seems to have something to do with tlp. By commenting out the lines


in my tlp config. I rebooted and since than never had issues. Booting with a dock, without one, connecting and disconnecting docks works fine for me. I have not investigated any deeper into the issue until now

Hashing them out did the trick. Still kernel related though. Something either changed intentionnally, or there is a regression. I am sure this will help narrow down the source of the issue. Thanks.

Apparently disabling those and using the following works. So maybe something was deprecated.

# Radio devices to enable/disable when docked.


# Radio devices to enable/disable when undocked.


Definitely going to dig into this over the weekend.

I do use tlp, but I don’t have the time to dig into atm.

I am not docked. And I completely disabled TLP. No dice, for 6.7.3 or 6.7.4.

EDIT: I tried 6.7.3 again, and it booted without issue. Then I re-enabled TLP, and it still booted. But either way, I now can’t get 6.7.4 to boot!

1 Like

Hmmm, the fact that this is happening with TLP indicates it’s not liking something in the config.

Let’s get you into a ticket as I’d like to see what your logs indicate.

My wording is confusing. I can’t get 6.7.4 to run with or without tlp. I am making the ticket. Some logs suggest this has something to do with luks?

Boot screen (I removed arguments starting with rhgb to see if any were causing this):

Edit: Added info from the ticket
Edit 2: I fixed (?) it again?!?!

I wanted to revert the default kernel to 6.7.3 for the time being, so I tried

sudo grubby --set-default /boot/vmlinuz-6.7.3-200.fc39.x86_64
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

and I rebooted, but grub loaded 6.7.4, and it actually booted.

I checked my system settings, which confirmed I booted into 6.7.4, but also --default-index and --default-kernel, which were consistent with 6.7.3.

Then I ran

sudo dnf reinstall kernel*-6.7.4

and verified --default-index and --default-kernel once again were 0 and 6.7.4.

Rebooting again, I couldn’t boot 6.7.4. Booting back into 6.7.3, I simply entered:

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

and booted into 6.7.4 successfully.

TLDR: For some reason, I could boot into 6.7.4 only after manually running sudo grub2-mkconfig -o /boot/grub2/grub.cfg . Slightly worryingly, I can’t seem to set a default kernel for grub (is that an issue)?

1 Like

13th gen Intel here, been stuck on kernel 6.6.8 for a while as the others would just hang. Did a Google search, found this, post, ran this command… done. All fixed! Now running 6.7.4 no trouble! Thank you!

1 Like

Huh. I’m glad I’m not alone. Have you done anything to modify Grub or the boot process? Do you have LUKS (disk encryption)? Are you dual booting windows (I used to)? Are you using TLP?

Yep, I messed with Grub.
Yes, LUKS.
Yes, dual boot Windows.
Yes, TLP.
Perfect storm? hah

I have your ticket, please look for my reply.

1 Like