[RESPONDED] Linux Mint GUI scale issues

Hey guys, I am having some issues with some applications. I have changed my GUI scale from the display settings to 150%. Now everything is much smaller which is what I wanted. However some applications are extremely small when in windowed mode. Also steam is quite small. What are possibe fixes to this issue? Any help is appreciated and also keep in mind I am relatively new to LInux.

If you’re having issues with the scaling on the display, it sounds like just a display setting issue in Linux Mint itself. There are a multitude of possible issues here, which could include an out of date kernel or a simple UI scaling issue.

I would recommend starting here to follow these possible options to update your scaling in Linux Mint under this sub-heading Increase the size of fonts, panel, icons and mouse pointer.

As can often help, it is nice to know great places to look for help. Teach a person to fish, after all. Other places to look for UI issues:


hi @Fares_Albakri welcome to the forums :slight_smile:

@coxdm recommendations looks solid, let us know if it resolved your issue or if you’re encountering other issues after doing the recommended steps.


1 Like

Hey thanks for your help guys, however it didn’t really work, my issue is that the GUI scale is fine on my browser and settings. It is only when I open other applications like Steam or an Appimage or any other downloaded programs that it gets messed up. I will try to do the solutions you mentioned one more time and see if it works this time. Regardless I appreciate the help!

If Steam is appearing small, there are a few options. Steam itself has a setting to “Enlarge text and icons based on monitor size (requires restart)”. Additionally, you can modify the Steam launcher to utilize scaling as shown in the link below.

1 Like

I’m not 100% sure, but I don’t think some apps scale well with the fractional scaling methods incorporated. What I have had to do in the past (on my SP4 with Pop) was create a new resolution entry which was the perfect res without the need for fractional scaling. Under xorg, this was achieved with xrandr commands. I think I used this link

Under Wayland, its a similar process but different commands of course.

Bit of a faff, but once you have it setup, you shouldn’t have any weird scaling issues.


If you are using Cinnamon, what I do is set the scaling to 100% and then set the font scaling factor to 1.5