[RESPONDED] Mapping function keys/hot keys for screen brightness on linux (and touchpad smooth zoom?)

Hi, I’m using a Framework laptop DIY with Manjaro Linux (Arch based). I’ve had success with most features of the laptop in the installation and am aware of the finickyness of Linux, but one issue I have yet to find an easy solution for is the hotkey and function key mapping for the framework keyboard. The function keys on their own work fine, but I prefer the Fn to be on “hotkey” mode (not sure which one is Fn lock, but I want to press the Fn key to refresh with F5).
So far, all three volume keys work under F1, F2, and F3, the Pause/Play works under F5, the Screen Display under F9, and Print Scrn under F11. I have no luck with F4 (Rewind), F6 (Fast Forward), F7 (Lower Brightness), F8 (Raise Brightness), F10 (Airplane Mode) or F12 (Framework Logo, not sure what this is supposed to be for).

There are keyboard layouts from specific laptops that I can install, does the Framework keyboard match any of them?

An additional question I had was regarding zooming in on the touchpad. I am used to being able to do a 2 finger zoom in and zoom out much like on a phone, but I don’t know how to get this feature to work in either X11 or Wayland (I’m using Plasma). If I could have my preferred way, I would be able to 2 finger zoom on the touchpad and this would cause an ordinary window to zoom in much like on a non-mobile site using a mobile browser (without affecting toolbars and menu bars). The Ctrl + 2 finger zoom would be identical to Ctrl + + or Ctrl + - zooming. I have installed fusuma if there is a way for this to work with that.

2 Likes

Simplest solution I know of is to use fn lock. Press fn + esc, that should do the trick. same to undo it.

Read this comment on brightness hotkeys

Not sure why others hotkeys are not working, maybe wrong keyboard layouts is selected?
I’m also on KDE Plasma, mine is selected to Generic 104-key PC. I am using a British English Keyboard if that matters.
Hopefully someone else can chime in about this.

I know Wayland has support for gestures in KDE. Double check the touchpad setting just to be sure. I do have tap-to-click enabled, rest was as is. I can use pinch to zoom in and out.
Hope this helps.

Simplest solution I know of is to use fn lock. Press fn + esc, that should do the trick. same to undo it.

I’m aware of how this works, however I am unsure about which binding is the “default” if I were to map the keys. Are the regular function keys (F1, F2, F3, etc.) considered by the system to be the same default bindings as the lower case letters? Or are the hot keys the default. I’m having trouble parsing the output from xmodmap -pk.

I have not tested if fn lock persists through reboots. As far as I understand, function Keys are not default and only work with fn key, unless fn lock is enabled.
I have no experiencing modifying key mapping, never tried to. Can’t offer you any help with xmodmap issues.

Btw, you can change the fkey mode in the BIOS.

Welcome to the community!

Cipher has touched anything I would have thought of.

I must confess I have never used pinch zoom on a laptop (just my phone), but it looks like there have been Manjaro users who have had success with it in the past. Once configured, there is also a GUI application available that adds a visual control layer as well.