[RESPONDED] Suspend/Sleep in Windows?

Hey all,

Just got my framework 13 and I’m enjoying it so far! But I can’t seem to get it to suspend/sleep properly. Most of the threads I’m seeing are Linux focused, I was wondering if anyone has troubleshooting advice for us dirty windows users? Trying to get it to sleep with the lid closed (while hooked to an external display). Even if I manually select sleep, when I come back the machine is off after a few hours.

It seems like it goes to sleep and then immediately wakes:

Event ID 42

The system is entering sleep.

Sleep Reason: Application API

Event ID 107 (one second later)

The system has resumed from sleep.


Hi Mike,

I’m not a Windows user myself, however this type of error is (I believe) usually reflecting of it going to sleep when you don’t want it to. Bear this in mind when reading below.

However, first thing - does it sleep without the external display attached? If it does, this could be a driver thing.

What application is usually open when it fails to sleep? Has it been tested without that application running?

That said, I dug through some notes I keep for random Windows stuff (be it untested by me:

Here are some things you can try to fix the issue:

** Check your power settings. Make sure that the “Sleep after” setting is set to a time that is longer than the amount of time you want your computer to stay awake.*
** Disable hybrid sleep. Hybrid sleep is a feature that allows your computer to save its state to the hard drive when it goes to sleep. This can sometimes cause problems with applications that are calling APIs to put the computer to sleep. To disable hybrid sleep, open the Power Options control panel and click on “Change plan settings” for the power plan that you are using. Then, click on “Change advanced power settings” and expand the “Sleep” section. Find the “Allow hybrid sleep” setting and set it to “Off”.*
** Update your drivers. Make sure that your drivers are up to date, especially your graphics card driver. Outdated drivers can sometimes cause problems with sleep mode.*
** Run the Power Troubleshooter. Windows has a built-in troubleshooter that can help you fix problems with power management. To run the Power Troubleshooter, open the Control Panel and search for “Power Troubleshooter”. Then, click on “Run the troubleshooter”.*

If you have tried all of these things and you are still having problems, you may need to contact the manufacturer of your computer for help.


No one really is a Windows user. We’re all victims. lol

Pretty awesome for the Linux pro @ Framework to take time to respond to this thread.



Have you tried the Powercfg command from a Command Prompt (DOS window with elevated Admin privileges)?

Powercfg /lastwake

Powercfg /sleepstudy

1 Like

Thank you @Matt_Hartley @Scott_H

  • Hybrid sleep isn’t enabled (I’m on win10 not sure its an option?), the troubleshooter didn’t find anything
  • I did install the latest drivers a few days ago from the Framework bundle, but device manager shows a few devices with missing drivers, USB and the HID custom sensor.
  • The sleepstudy option is really interesting, it shows a battery drain while plugged in? And whatever this is: Unregistered Device \_SB.PC00.TDM0 causing a drain … This doesn’t seem to correspond to the hardware IDs of the driverless devices, and the only mention I can find is an a Lenovo thread about Thunderbolt controllers.

I’ll keep poking at it, maybe I can fix the driver issues.

EDIT: Ah my guess is that the USB/PCI drivers are Win11 only and that might be part of the problem…

What Framework hardware do you have? Windows 10 does not have proper support on 12th gen and 13th gen.

Its 13th gen. I guess I should upgrade.

1 Like