[RESPONDED] Troubleshooting power use - Powertop and 100% USB Utilization

Hi guys,

How can I troubleshoot this one USB device drawing the 8 or so watts in powertop? I have no USB devices connected, but I have two USB C, One USB A, and one HDMI slots in the framework currently. Appreciate any help!

Hi and welcome to the forum.

There are issue with the USB A and HDMI

Have you tried with neither or only one to see what is happening, also search the forum for lots more info.

The hdmi and usb-a are almost definitely the culprits but you likely also have turboboost enabled on battery. For battery life TLP and all usb-c expansion cards are the way to go.


@nadb Turning off turboboost has made a significant difference, and yeah I have tlp installed too. Thanks for the help as well @amoun


This sounds like the HDMI expansion card is at play here. They can use a bit more power than other card. Have you tried testing one card at a time, to see if this may indeed be the HDMI card drawing the wattage?

1 Like